Wheres the DRIVER?

why is there such an issue here with this sansa e260 4bg mp3 player to hook up via usb? I did the updater for firmware but still same thing connects…disconnects…please post a link where i can get it.

thank you

A driver is something Windows needs in order to talk to a device. They’re built in to Windows XP and Vista, and I’ve even heard of other versions of Windows working too. There aren’t any for the Sansa that I know of- they’re not needed.

Try a different USB port, make sure the computer’s power is plugged in (if it’s a laptop,) otherwise try a different computer- maybe your cable is bad.

If you want to use MSC mode, no driver is required. If you wish to sync it up, make sure you have the latest WMP. Good luck :slight_smile:

i have tried other ports everything else on my comp works. its the driver. any other product i buy comes with software why does this little cd have nothing on it? if there is an admin here please gimme link to usb driver for this e260 4mb mp3 player, this is really fustrating:angry:

THERE IS NO DRIVER NECESSARY.

-if you already updated the firmware, you should be ok.

-Have you tried a different computer?

You might have a bad USB cord. Do you know anyone else with a Sansa whose cord you could try? Or you can find a replacement cord on Amazon or Ebay for about $5.

What operating system are you using?

In MSC mode, the driver is the generic USB driver already built into XP or Vista.

In MTP mode, the driver is in Windows Media Player 10 or 11.

If you’re trying to use Windows 98 or Windows 2000/ME, or if your Windows Media Player is an earlier version, you’ll have problems.

The software on the CD is the Media Converter for photos and videos. There’s no secret mystery driver being withheld from you.

I am using xp pro i want to import my mp3 into my folders with windows exporer and manullly put them in. But the connection is jerky. I have updated the firmware which should use a cd with a program to send files there the rapsody is weak when you get a digital camera it comes with an installation cd why doest this? I see alot of people who are having the same problems so its not me it your bs firmware my player goes from cinnected to disconnected i see the drives in the my computer window but pops in and out, its looking for the usb driver for this player, i cant believe there isnt one out there…

I was having the same problem with Windows saying it cannot find the driver.  I did some research online and found out that I needed to re-install Windows Media Player.  It works fine now.  Follow the link below.

http://www.microsoft.com/windows/windowsmedia/download/AllDownloads.aspx?displang=en&qstechnology=

Message Edited by bsmith781 on 12-26-2007 09:19 PM

ok i’ll try that thanks i’ll let ya know how it worked

Maybe this is your problem. Never hurts to actually look at the official FAQ.

relvis wrote:

…i see the drives in the my computer window but pops in and out, its looking for the usb driver for this player, i cant believe there isnt one out there…

You can’t believe that someone would actually make a device that you DON’T HAVE TO install a bunch of other crap?

That someone would actually design a device that just plugs into Windows and it just works?

Ok.  Congratulations.

You might try hitting ctrl-alt-del go to “processes” and turn off programs windows doesn’t need- maybe other software is interfering. (like the link just above says.)

Otherwise you might have a bad cable or a bad mp3 player. Exchange it at the store if you can, maybe that will solve the problem.

relvis is correct…this is an incredibly frustrating problem when trying to use these players. I, too, have fought with this annoying problem. Here are the details: OS is WinXP Pro SP2, a fresh intall on a Dell Optiplex GX260. I needed to do two things to resolve this problem: first, I installed the latest Intel Chipset driver and second I installed Windows Media Player 11. I suspect that Windows Media Player had more to do with resolving this issue than the chipset driver as once Windows Media Player 11 was installed, it worked just fine.

So should you be experiencing this issue, make sure that you are running Windows Media Player 11. It is very frustrating to have this happen and not find any real answers other than “it doesn’t need a driver!”.

Hope this helps.

2nd reply said “MAKE SURE YOU HAVE THE LATEST WMP.”

Although that only matters if you’re connecting in MTP mode.
In MSC mode the drivers are already in Windows, because the Sansa is configured to work like a regular USB storage drive.

So actually making sure you have the right chipset drivers IS CRITICAL because otherwise your motherboard (which runs the built-in USB) has to know how to communicate.

(For What It’s Worth I had the USB go bad on a computer a while back. Even when the computer was new it didn’t like certain joysticks, etc…  I ended up putting in a $15 PCI USB card and never had any issues plugging ANYTHING into that…)

Windows XP comes with WMP 9. People who have Windows 98 or Windows 2000 or who never updated Windows XP (despite the constant nagging from Windows Uptate or WMP) and who don’t read the box or the approximately 6.487 posts that say that for MTP mode the Sansa needs Windows Media Player 10 or 11 seem most eager to complain. 

Maybe this is the driver everybody seems to be searching for . . .

:smileyvery-happy:

I got it to connect on Windows XP Pro x64 SP2.

It did not connect at first, though. After plugging in the usb cable, I had to select a language on the Sansa by pressing next. The device immediately started connecting with Windows and the Sansa showed up in Windows Explorer under the Other category as Sansa c250. Nothing happened until I selected a language.

Hello Friends ,

i have also using sandisk sansa e260v2 R player.  First u r enter in SETTING menu then press USB MODE and please select the  MSC option and click Ok then U connect ur player to pc and its work properly and Enjoy the Music with sansa…

Nilesh Shah

Surendranagar.Gujarat.India

nilesh6577@gmail.com