What should I do – I don’t want to give up - the data!

My Sandisk Cruzer Titanium 8G with U3 Lanch was send to 3 different data recover shop(two in cn & one in hk - they are good but not enough experience & equipments for Sandisk). All they said can not help to repair that flash drives. Anybody can help to advice me any sandisk specialist - where should the flash drives sent to for repair or recover the data?

What happen of the flash drives:

U3 Launch Pad does not auto run. Can not manual by double click the U3 disk drive symbol because that symbol disappeared on “my computer” so no way to type password to get into the files…


1.U3 disk drive symbol disappeared.

  1. flash drives symbol still in “my computer but no response(right click also no response – only a sandglass run a while).

  2. Divece light still on as normal.

Cause of Failure:

Not sure


here is the bad news. if the drive is password protected and it has failed there is absolutly no way to get your data back. all the data is encrypted and there is no back door into the security.

have you check to see if it is just a drive letter conflict that is causing the U3 partition not to mount? 

What OS are you running on your pc?  Microsoft disabled the Autorun functionality of Windows XP over a year ago and I don’t think it was ever an option in Windows 7.  AutoPlay however should open a window for you to open the drive in Windows Explorer.

Have you tried the U3 flash drive in another computer?  In another USB port?  Are other USB devices plugged in, if so unplug them and reboot.

RIGHT click on (My) Computer, click on Manage, then click on Disk Management.  Does the flash drive show a drive letter assigned to the U3 CD drive?

Above the Disk Management link click on the Device Manager link and in the window that opens click on the Disk drives link.  Do you see 2 drivers for Sandisk U3 devices?

the drive letter was checked. Thanks

  1. Window XP are running.

2.I have tried he U3 flash drive in another computer and other USB port , same case. no other USB devices plugged in.

3.It does not show a drive letter on (My)Computer / Management but only show a drive letter on (My)Computer

4.on Device Manage, only 1 drivers(SanDisk U3 Titanium USB Device) was shown.


4.on Device Manage, only 1 drivers(SanDisk U3 Titanium USB Device) was shown.

:cry:  I think your USB drive has gone to the bit bucket in the sky.

You can try lightly sanding the drive’s contacts with emory paper but I don’t hold much hope for that fixing this problem.  Sorry.