What ID3 Tag s/w can get artist/album info from folder & subfolder automatically?

All my files are in this format:

Artist1/Album1/01 - Track1.mp3, 02 - Track2.mp3, etc.

Artist1/Album2/01 - Track1.mp3 …


I’m looking for a tagging software that will pull the artist and album name from these folders automatically, anyone know of one? Also would be nice to apply a global genre to multiple folders.


Check out mp3tag, you can define a format string for your filenames (including slashes) to extract the tag info (I believe %artist%/%album%/%track% - %title% should work for you):


Sweet, this is perfect. Thanks for the quick reply

I’m having the same problem as you do(well…did) but i don’t seem to be able to manage this one.Can you give me some steps or so?

 I browse to the my music directory press enter and the 3000+ tracks are loaded then after ctrl+a i click convert–>filename-tag but the ok option is not available…

p.s.most of my artist  folders don’t have (album) subfolders will the command be “%artist%/” in my cas,all i want is to change the artist id3 tag i’m not interested about other tags.I would appreciate your help.

Yes, if it’s as you say then you would have to type something like %artist%/%track%-%title%. However as you type the program will be showing (in the very same dialog window) a preview of how the tags will be extracted. You can also hit the ‘Preview’ button and it will show you how the extraction will be performed for all the selected songs.

If you are not seeing anything in the preview, you may have been doing some mistake or not completing something (i.e., if you type ‘%artist%/%title’ nothing will appear until you type the closing ‘%’). Also, be aware of spaces: if you type ‘%track% - %title%’ and your filenames do not have spaces around the ‘-’, the extraction will not be correct.

Good luck.

Thanks for your quick reply but the main problem is that the ok button is not available,clicking it does nothing meaning i can’t even experiment with the commands…hopefully this will enlighten you a bit:


Put a backslash () instead of the slash (/).

(Luckily you posted a picture!! Without it I would never realized about that… besides, all the previous posts are strictly wrong).

Message Edited by porio on 07-31-2008 05:52 PM

And with your last post you officially qualify as my savior…all that time i was copy-pasting those commands in case I would make a mistake…and look where it got me…anyway I’m Greek and there is no word for backslash here (seriously thinking about it…there is no word for backslash?How weird is that?)and by reading backslash my brain automatically “redirects” in slash…anyway thanks for your help if you need a Greek translation in the future i’d be happy to assist you.(“backslash” qualifies as an exception)

p.s.do you happen to know an end command or something?E.G.“%artist%%track%” works but i only want the artist tag to change and "%artist%" doesn’t…i think i found it it’s the dummy option of the droplist correct me if i’m wrong.

Message Edited by mhtsos on 08-01-2008 01:08 AM

It seems that %artist%%dummy% will work for you. At least it did in the preview, but I didn’t try it in the real case.

BTW, in spanish there is no word for backslash either!!