What a piece of junk

No thankyou sansa, I have stopped using my clip and gone back to my small capacity (other brand) player.

I just could not get it to function in any reasonable way. This thing is full of bugs and reading through the forum is scary! I am not alone then. There is just too much crazy behaviour to tell about. I have tried formatting from the device itself, that did nothing, I then tried formatting from windows by rightclicking and chooseing format. That didnt get this thing to function any better.   When I do eventually get this thing to startup ALL the music is still there!  I wanted to try dragging the bin file of the new firmware into the root dir but I am not allowed, I get a “you do not have permission” and yes I am the Administrator so its not that. I had already managed a while back to update the firmware via the Sansa updater software but was so desparate thought i would try the manual way too. I find this device totally unusable, I give up and will never buy Sansa again.

Why do you keep posting the same message to different threads in this forum?  That’s abusive. 

I wish you simply would have telephoned SanDisk customer service for assistance …

co-sign, this is just silly.  If it doesn’t work return it.  I believe you said it was a UK clip.  We have pretty awesome laws that mean we can return items for a refund.  It’s not rocket science.

yeah I suppose in theory I am entitled to a refund but getting money out of companies is often not that easy - they are more likely to send me another and I have had it up to here with sansa clip!  As it was only 24 pounds I am just putting it down to experience. As I cant be bothered with the hassle of postage and then getting another one and sending that back etc. It is further coplicated by the fact that i am now in Holland and the company is in the uk

The chances of you getting another Sansa Clip with a non-working Format function are probably less than you getting hit in the head by lightning while winning the lottery.