WFD64GB is working only as 64GB exFAT USB storage media - Mac OS 10.9

Questions to Mac users.  Has your experience using SanDisk Wireless Flash Drive been trouble-free?

I purchased a SanDisk Wireless Flash Drive 64GB which I will call WFD64GB henceforth.  After taking it out of the package, first thing I did was to reformat it to Mac OS extended using Disk Utility on my MacBook Pro running OS10.9.  Oh, how dumb!  I know.  It was an accident.  After running into numerous problems, I contacted SanDisk support and was told to reformat it back to exFAT.  So I did with my MBP.  And….

1.  WFD64GB works as a 64GB exFAT USB storage media plugged into MBP’s USB port.  It mounts on my MBP as such.
2.  WFD64GB creates its own network when unplugged from the computer and turned on:  SanDisk Flash F94739.
3.  My MBP can connect to the SanDisk network.
4.  My iPhone (iOS 7.1) can connect to the SanDisk network and the WFD64G via SanDisk app.


5.  San Disk Wireless Flash app on my iPhone says, after connecting to the WFD64GB,  “The memory card file system is not supported” and won’t show the folders or files on it.
6.  My MBP cannot connect to the WFD64GB via web browser, Cyberduck, or Mac OS Finder/Go/Connect to Server.  I’ve followed kb instructions on how to do them while connected to the SanDisk network without Internet access and while connected to the local WiFi network with Internet access.

I have exchanged emails with SanDisk support and so far no luck resolving these issues.  I will appreciate any suggestions.  Thanks!

I tried formatting the card into mac extended OS and then back to exFAT and the WFD app worked normally after formatting the card back to exFAT. 

I would start with performing a factory reset of the WFD 

then make sure you have fully closed the WFD app by double tapping the home button and swiping the WFD app up to fully close it. Then connect back to the WFD SSID and reopen the app. 

Thank you so much!  The last time I reformatted the card to exFAT and reset the WFD to factory settings, it did not resolve the issue.  But it is now working!  It feels almost like some sort of voodoo.  

I’m nost sure if it made any difference, but what I did differently this time:

  • erase/format at the disk level instead of the volume level
  • increased security level to writing zeros (1 pass) instead of fast erase

After resetting the drive as instructed on the kb link, I unplugged the WFD and turned it on.  Connecting the MacBook Pro to the SanDisk network and typing in brought up the details of the WFD!   And the iPhone app connected to the SD network was able to connect to the WFD and see that it is empty.  

Thank you again for encouraging me to try it again.  Your input is much appreciated.