Volume not working after update

I’ve had a Sansa Clip+ for a few years now and have never updated the firmware.  A couple of weeks ago, I did.  Since then my volume doesn’t adjust at all.  I have tried downloading all of the older versions I can find with no change in result.  Any suggestions?

By way of a bit more info, the forward/back buttons quit skipping at the same time.  In order to skip forward or back now, I have to pause and hold the button down.  After a short pause, it starts cycling.  Kind of a pain to time letting go right.

You might try a reformat of the player, under its System settings.  Note:  transfer anything you want to save to your computer first (if possible).

I have tried formatting it, and restting to factory settings.  Neither helped.  Changing the volume from high to low has no affect on tholume level either.

Changing the volume setting from LOW to HIGH in Settings > System Settings only changes the maximum volume levels. To adjust the volume for normal everyday listening, use the rocker switch on the side.

That not working since the firmware update is what started this thread.  The volume doesn’t adjust at all.  the rocker switch no longer does anything.

Try manually re-applying the firmware.


I have done that.  I have manually installed every version of the firmware that I could find.  I am back to 1.2.18.

I’ve never seen another instance here of a firmware update disabling the buttons. And if you’ve tried other firmware and formatted, you’ve wiped out every trace of what could make the processor go wrong.

Since you’ve had it for years, it may be some mechanical aspect is wearing out, and it happened to coincide with the firmware update.  But it is a bizarre coincidence.

You might post your problem at AnythingButIpod, where a different crowd does more mechanical tinkering with mp3 players.


It sounds like you’re pretty computer-savvy. If you feel geeky and experimental you could install the alternative Rockbox firmware at www.rockbox.org, which is an entirely different operating system made by dedicated open-source tinkerers. Follow its install instructions carefully so you’ll be able to uninstall it without problems.   If the buttons still aren’t working with Rockbox, I’d guess it’s just worn out. 

We have heard here however of the volume rocker switch failing, or the solder joints to it. Not very often, but it occasionally happens. If you’re handy with a very small-tipped soldering iron, you might be able to fix it.

As BR said, it might be a hardware failure that just happened to coincide with updating the firmware.

I agree that it would be a bizarre coincidence.  I’ll give rockbox a shot. If that doesn’t fix it, I’ll just figure that I got my $5 worth and keep an eye on woot for another cheap mp3 player.  I lack finesse with a soldering iron.

Looks like maybe it was a freak toggle failure.  Installed rockbock and the toggle still doesn’t work to adjust the volume, but I can adjust it through the settings which I can live with.  Thanks for the help.