USB Device Not Recognized with both XP SP3/WMP11 & Win 7 64-bit PCs

Can anyone help…

I’ve got 3 PCs…

  1. XP Pro SP3 with WMP11 installed

  2. Win 2003 server

  3. Win 7 64-bit (notebook)

On the Win2003 machine, my Clip+ works fine, but on either of the other two, I just get “USB Device Not Recognized”.  I’ve tried setting the Clip+ to MSC mode and switching off/on.  No difference.  In MTP mode on the 2003 box, it works fine. 

I’ve tried removing the “unknown device” and rebooting the machines… no difference… tried connecting whilst holding down centre button… no difference.

I’ve tried three different USB cables and ports… two have chokes, one doesn’t… no difference…

I’m tearing my hair out (and I don’t have much left).  From reading another thread on the Clip board, this is quite a common problem.

Update - I just tried it again on my Win2003 box and I get the same error… I’m assuming the device is broken therefore and I’ll return it to the retailer for swapping out.

Message Edited by say170 on 06-06-2010 09:46 PM