USB Recognition Error on XP SP3

This maybe the same or similar to ManOMullet’s issue.

Whenever I connect my new Sansa Clip+ to my XP V2002 SP3 with all the latest Microsoft updates, the system refuses to connect it up as a USB device.  The Setup->System->Hardware->Device Manager shows the USB port with the message: “This device cannot start: Code 10”.  I took the Troubleshooting advice and uninstalled that USB port.  I plug it in, it finds it as new hardware, munges for a while and then tells me that it is having a problem during hardware installation.  The Device Manage shows the same message again: “This device cannot start: Code 10”.

However,  when I attach this to an older XP only up to SP2, the device attaches immediately and works perfectly.

I am limping along loading from this second computer, but I will need to be able to attach the Sansa to this computer because it is the one connected to the Internet.

Switch the USB mode to MSC.  It should connect fine after that, but be aware that anything loaded in MTP mode cannot be viewed on the PC when in MSC mode, so it may be worth deleting what you already have on there and reloading it in MSC mode.

I had read through the documentation, found this suggestion and tried to do it.  The problem was - I could not find anything like this on my XP sytem.  When I go to  Settings->Control Panel  there is nothing like USB Mode in the list.  So, I went to System, again, nothing like USB Mode.  I have searched through all the Administration Tool Applications for anything like USB, USB Mode or MSC, again nothing.  Maybe I missed something.

My bad, I should have explained that you need to change it on the device itself!  Navigate to settings, system settings, usb mode if I remember right.

After a Google search for “sansa clip+ XP driver” I found:

One of the suggestions was to upgrade the Media Player to version 11.  I wasn’t going to, but …  I did and now the Sansa Clip+ mounts!

Let’s say that this is solved.

Google ‘sansa MTP MSC’. In MSC mode, the Sansa will mount like a removeable USB drive, so you can just drop songs in there. If you have DRM’d songs, though, you have to use MTP mode, which then you use Windows Media Player to load the songs. So maybe that was why it wasn’t connecting and kept asking for driver installation.