Sansa Clip + Windows XP SP3 ????

Will this combination ever work together? On the main driver page there is SP3 not even listed and by default drivers are not included and device not recognized :frowning: worked fine for me when on SP2… Pls help

I am running several machines with Service Pack 3, all happy with the Sansas.  Are you trying to connect in MSC or MTP mode?  MTP is more fragile, and Windows Media Player 11 is the hot ticket for that, running XP.

Bob  :smileyvery-happy:

My Clips work fine on SP3 (MTP mode). However, to get them to do so, I had to add “Local Service” to the Administrators group. Until I did that, I was getting an error saying “t_his device cannot start [Code 10]”_

More info in this thread.

Message Edited by bwaldron on 12-14-2008 08:40 PM

Just a quick footnote on the link solution.  The command syntax is a wee bit different than shown.

It was listed as:

 Net localgroup Administrators local service /add

The correct syntax is :

 Net localgroup Administrators localservice /add

There’s no space in “localservice”.

Bob  :wink:

In theory, since the USB drivers for recognising the Clip come standard in every version of Windows from Millenium on (or in MTP mode anyhow, I’ve never understood the voluntary complication of using Windows Media Player) there should not be an issue using the Clip with XP SP3 or any rendition of Vista.  Individual mileage will vary of course since we are talking about Windows here.  But I have heard of stuff that worked fine in SP2 break when SP3 is installed, it sort of boggles certain USB drivers. 

“this device cannot start [Code 10]” is a fairly common error in XP when it comes to removable USB storage – in a previous tech gig I’d get a call about once a week relating to Maxtor portable drives not being recognised by one computer yet working fine in any other – and the simple solution is to try a different USB port, while the more convoluted solution is to search through the Registry looking for where it stores its data about the USB devices that have been plugged into the computer and delete the references to the thing it basically identifies as something it doesn’t want to work correctly with anymore.  :)  (I have had to do that with my old Canon scanner; not even Canon could fix the non-recognision issue with its driver/INF removal tools alone.)