Update 1.210 issue

I recently updated my Sansa e260 with version 1.210. It was playing my songs fine and then out of nowhere, when I tried going to the next song, it said “Bad track” about 4-5 times before playing a song. And also, I had about 386 songs on my e260 but now there are only 60 songs available. I have my device running in MSC mode because when I switch to MTP, my laptop (running Vista) does not recognize the device. When I go to the MUSIC folder when in MSC mode, none of my files are showing up…just folders with artist names. Is there a way to revert back to the previous update? Or is there a way to solve this issue? Thanks for any help.

Message Edited by Seventhree on 09-12-2009 11:32 AM

Firstly, there is no firmware version 1.210. That is the Sansa Updater which would have nothing to do with your problem. And by posting in this board could explain why you’re getting a ‘limited’ response. You’d be better off posting in the e200 board.

The Updater is not necessary. Period. Uninstall it from your system.

  1. There will be no further firmware updates for this model so it won’t be needed.
  2. It is a system resource hog and slows your computer down considerably.
  3. It trys to find a new f/w version every time you plug your player into your computer. Since it won’t find any, but insists on telling you anyway, it is nothing more than ‘nag-ware’.
  4. The Updater won’t be able to tell if your firmware is corrupted, only if a newer version is available.
  5. It’s just as easy to manually update your firmware yourself.

The ‘Bad Track’ message indicates corrupted files. You can run ChkDsk or simply format the player’s memory. Note: formatting will erase everything (but not firmware or operating files) giving you a clean slate from which to start over. This won’t do any good though, unless you fix the corrupted files.

You didn’t indicate which version of player you have, but here are the latest firmware updates for each. If, after running ChkDsk and/or formatting, you still have a problem you could try re-installing the f/w.

e200 v1

e200 v2

I’m running v1 on my e260. I’ve tried running ChkDsk and it fixed the errors the first time, but songs were still missing. After the device restarted, I checked the Info in Settings and it showed as v1. I’ve installed firmware v1 and it still shows only 60 of the 385 songs I have on the device. I’m still reading through the FAQs and have yet to find a direct question/issue related to the problem I’m having. I know the songs are still there due to the 204MB of free space I still have on the 4GB device. Thank you for the help, Tapeworm. It’s frustrating, but I’m not giving up or whatever. Should I post this thread again in the e200 section?

How are your ID3 tags? That’s the only way the player can ‘see’ the song, you know. The link I provided to the ChkDsk info in my last reply also gave a quick primer on ID3 tags.

I’m thinking that if your tags are the wrong format, not filled out properly or missing all together, that might account for the ‘missing’ songs. Do any of these show up on the player’s menus under ‘Unknown’?

There are certain folders and/or songs that appear as “Unknown”, but they usually played just fine. I haven’t gone through the 60 songs that are shown to see whether any appear as “Unknown” or not. At one point in the past when it said “Bad track”, I ran ChkDsk and it fixed the problem. Right now, after I’ve updated to v1, I still only see the 60 songs instead of 385. I’ve had it in MSC and I’ve unhidden the MUSIC folder, but the songs aren’t showing up in there so I can’t really check the ID3 tags for the songs that are missing.