Unit keep playing music when I connect to PC.

My niece’s Sansa Clip is having problems. Whenever I plug it to a computer, it charges the battery but it starts playing the last tune it was playing instead of allowing me to input any new music. It doesn’t show connected to PC on the screen.

Here is what I tried:

  1. In the settings I did a Reset All
  2. Changed the USB mode to MTP
  3. Changed the USP mode to MSC
  4. Turned the unit off and put the button in the Hold position then pluged the USB cable to the PC
  5. Tried on 3 different PCs (another unit of the same model works fine
  6. Tried on Windows XP sp3, on Linux Mint 7 and on Windows Trust 4 (based on Windows 2003)
  7. Tried with 3 different cables (another unit of the same model works fine)

What I haven’t tried :

Format the clip as it play the music properly, I am afraid to format it and not be able to do anything after.

Current firmware : V01.01.20A

Thanks for your help

Short of reformatting, you could try re-applying the firmware–the code could have become corrupted.  See the firmware upgrade thread at the top of the forum.

I looked at the instructions:

  1. Ensure your battery is > 50% full. OK
  2. Extract the .zip file into a folder on your computer. OK
  3. Once extracted, drag the file to the root directory of your Sansa Clip. Can’t see the root directory since the music is still playing on the unit
  4. Disconnect the Sansa Clip and let it restart.
  5. The firmware update will now begin.
  6. Once it finally finishes doing its update, it will boot back up. Once its back to the main menu, head to “Settings” > “System Info”, and verify the “Version” is now 01.01.32.

As I wrote earlier, the unit is charging, but I can’t seems to have access to the memory. 

I don’t know if I miss something, but how do you you access the memory of the unit if it’s not going into data transfer mode?

Yep, you’re right …

You’re running out of options (and have tried so many).  For some reason, a data connection isn’t being made. 

I’d try a soft reset (which I don’t recall your having done, yet):  Clip off and disconnected, hold the on switch uppermost for 15-20 seconds.

If that doesn’t work, the only options I can see is doing a reformat under the Clip’s settings; or (most drastically) letting the Clip’s battery totally discharge and then trying to connect (my concern here is, what if you can’t and the Clip won’t recharge?).   

I hate to ask, but:  are you still under warranty?