Unable to update firmware on Extreme 480GB drives Dashboard seems to be useless junk

Hi,
I have some older 480GB Sandisk Exterme SATA SSD (Manufactured July 2012)
Running latest Dashboard (Version 3.2.2.9) (on Windows 10 64bit pro clean install and up to date)

Dashboard shows suggests and recommends newer firmware: (R211)
Current firmware on drives is R201.

Of course you cannot update firmware on these drives from Dashboard.
If you click [UPDATE FIRMWARE]
It gives a big giant useless “Firmware Update Failed” with absolutely NO information whatsoever.
WHY even suggest you can update firmware in Dashboard if you cannot?
This is garbage!

Next: I create a bootable USB drive (tried this multiple times and on different computers/hardware!)
PLEASE don’t ask me things like if I made sure my bios is set to ACHI etc. etc. or unplugged other drives etc. and unplugged other usb devices etc. I know what I am doing here.
Seriously.
And I have tried completely different systems/hardware chipsets.
All are failing same way!

The bootable firmware flasher (created in Dashboard) identifies the drive.
If you try to flash/upgrade it you get an error: " Firmware Download Failed - Binary Could Not Be Opened.

Same problem, different hardware/motherboard/chipsets different usb drives etc. FAILS.

Next I manually create an ISO and burn a disk + make a bootable USB drive from it:

From this page: https://kb.sandisk.com/app/answers/detail/a_id/10476/~/sandisk-extreme-ssd-manual-firmware-update-version-r211

Mine is the 480GB.

Disk or USB boot Says: Waiting for devices to settle then shows my drive Selected in upper Left
SANDISK ADSSDX480GG25

Howeve systems is completely froze and locked up at this point, hard freeze. no keyboard or
Caps lock…

Same happens with USB or CDROM boot!
And same happens when booting it on ANY system. :frowning:

I figured it out on my own!
This absolutely requires that you run it on an ancient OLD computer and a PS/2 keyboard.
This ABSOLUTELY will not work on ANY computer with a USB keyboard period.
PC’s and motherboards WITHOUT ps/2 connectors came out around 2006 and by 2012
They were pretty much nonexistent on anything new.
This drive was manufactured July 2012 and firmware update is from 2013.
Shame City.

It also requires you to burn a CD and boot that.
It does not work if you make a bootable USB from the ISO.
It also does bot work at all and under any circumstances if you try to use the bootable USB that you
make from the dashboard software!
Pure useless garbage.
No good or usable documentation on this to be found anywhere on the forum or web searches.
Bad on Sandisk/WD for not at least letting us know anything on this anywhere.

There are reasons why I have been using Samsung SSDs since 2012.
Now there’s another reason.

I hope this helps somebody else out there.
I spent a couple of hours fighting with the uselessness.