Unable to open usb drive

When I insert the usb drive the normal file I open is not present, meaning I cannot open and files. The missing file is where is use my password.

Did you delete it? Did anyone else use your USB drive and delete it? Are there other files & folders on the drive? Is the missing file in your Recycle Bin? If it is right click on it and select Restore.

From a Command Prompt try running a chkdsk /f command for the USB’s drive letter.

No one else has access to it. The missing file is not in the Recycle Bin.

If you’re having trouble accessing files on a USB drive, try these steps: test the USB drive on another device to see if the issue persists, ensure a secure connection, and check your computer’s settings to display hidden files. Run an antivirus scan to rule out malware. If files are still inaccessible, use data recovery software. Regularly back up critical data on USB drives to prevent data loss

I ran Norton over the disk, no issues. Tried to view hidden files, nothing shows up.

The actual files are still there, I just cant open the drive.