Can't access files on computer

I have a SanDisk Cruzer USB Flash drive.  I was deleting some files and think I deleted something important.

When I plug the flash drive into a computer, the USB port recognizes it as a SanDisk Cruzer, but it shows no files.  I plug the flash drive into the usb port of my dvd player and I can see the files, play music files and see jpegs I have on the flash drive.  So the files are still there.

So how do I get access to the files on my computer?  In deleting files, I think I deleted BootEx.log.  Could that be part of the problem and how do I fix it?

Thanks.

What are you using on your computer to see the files?  Windows Explorer or something else?

The three computers I’ve tried it on have all been Windows Explorer.

At a Command Prompt window does a DIR command for the drive show the files?

At the Command Prompt, when I try to change the drive it says “The System cannot find the drive specified.”  

I then went over to “Device Manager” in Windows and it shows “SanDisk Cruzer USB Device” under the Disk Drive listing.  (So I know the USB port recognizes the drive)

I then tried a different flash drive at the Command Prompt and it listed all the files on that drive.  (Just to reassure myself I was doing it correctly in Command Prompt)

This evening I played some of the music files on the flash drive through my dvd player.  I tried transfering a file from a cd to the flash drive, but it told me “USB Device disconnected” after I had just played a music file from it. 

At the Command Prompt, when I try to change the drive it says "The System cannot find the drive specified."

Windows does not always assign the same drive letter to different devices.  And sometimes it does.  It’s just what Windows does.  I have a couple of USB drives that get assigned the J: drive letter and similar ones that get the S: drive letter and sometimes they switch.

Look at Windows Explorer, see what drive letter is assigned to the USB drive then use that in the DIR command. DIR D:\ or DIR E:\ or DIR F:\ etc until you see a list of files and directories.  No need to “change the drive”, the DIR command will run just find from the C: drive.

The DIR F:\ at command prompt gave me “The system cannot find the file specified.”

And F: is the drive letter shown for the drive in Device Manager?

Yes, that is correct.  

After I tried it with the defective flash drive, I put a good flash drive into the usb port and it listed all the files on the good flash drive.

hmmm It seems that the drive’s Super Floppy format has gotten damaged.  Maybe this link will help you.  https://forum.acronis.com/forum/27035

Let us know too on how this worked out for you.