Unable to copy files 4GB+ to a 64GB Cruzer Glide with Secure Access V3.0 - formatted to NTFS

I’m trying to copy (right click copy and then paste) a backup folder located on a fully up to date Windows 10 laptop, to one of the Cruzer Glide 32GB or 64GB USB drives, into their Secure Access V3.0 vault. Everything gets copied except the >4GB files.

One of the files in the source folder is named .System, and it’s a protected operating system file from a Garmin nuvi. After I update the maps on my nuvi, I take a full copy of it directly from the nuvi (plugged into my Win10 laptop) and save it to my hard drive. It copies fine.

Then, when I try to copy the same file folder containing the .System file from the laptop to the 32 or 64 GB USB drive’s secure vault, it won’t copy it. As a test, I can manually copy it from the back up folder on the laptop, to the desktop on the laptop. I have changed the “Files and Folders” view options to “unhide” these files, and all other hidden system files. 

To recap, this is what I have done, which doesn’t seem to copy the 6GB .System file. It copies everything else in the same folder. Just not the large file. My theory is it has something to do with FAT32 versus NTFS formatting of the USB drive, but I’m not sure.

The drives came in FAT32 format. I deleted all data on the target USB drive.

I then quick formatted the USB drive to NTFS, with max available space, and 4096 file size. Successful.

I then downloaded the V3.0 software from the Sandisk website. Copied it to the USB drive, and run as Administrator, and set the password, etc. for the Secure Access V3.0 software and vault. Successful.

I then plug in the USB drive, and open the vault, and right click and copy the folder on the Win10 laptop containing the >4GB files, then paste them into the vault in the USB drive.

It copies everything, except the oversized file.

Is there something in the Secure Access V3.0 vault or software that thinks it’s still in FAT32 format? If so, is there a fix for this issue? Is there some other flaw in my process steps? What am I missing or doing wrong?

Thanks for any info, suggestions, or comiseration.

64GB drives and larger are factory formated as exFAT and handle large files.  If the 64GB one you bought was FAT it would imply that it was used or counterfeit.  For the 32GB drive to handle large files, those over 4GB, format it as exFAT not NTFS. 

Not all files that one puts on a flash drive need to be put into the SecureAccess vault.  Only ones that contain sensitive data need to be put in it.  Others can be stored on the drive using regular Windows Explorer rather than SecureAccess.

Hi Ed,

      Thanks for the info and suggestions. I actually have 1 X 32GB and 4 X 64GB USB drives and all were purchased at Walmart USA over the last year. The larger .System file I’m trying to encrypt/backup, is trying to go to the vault on one of the 64GB drives. 

      So, they should have been factory formatted to exFAT? Hmm, that’s interesting, because I’m sure they were all simply FAT32, before I reformatted them to NTFS. I’ll reformat the ones that have the issue to exFAT, and give it another shot. I should have already done that, but was getting tired of chasing my tail. 

I’ll post up my results, good or bad. 



Tried reformatting the 32GB drive to exFAT, and then reinstalling the Secure Access V3.0 software. Then tried copying the folder again, and it still ignored the .System file/folder. 

While pondering the latest failure, I noticed the .System folder in the nuvi device backup on my laptop looked like it wasn’t fully visible, like it was semi-transparent. I found this odd, since I had unchecked both the “hide hidden files” and “hide protected operating system files and folders” in the view options list under folder options. It was the equivalent of “grayed out”.

On spec, I tried right clicking the .System folder, and selected the Properties option. I unchecked the “hidden” attribute, and applied it to all folders, subfolders, and files, clicked Apply, and OK’ed out of it.

The .System folder then appeared to be fully exposed/no longer hidden. Not transparent any more. 

Tried the right click, copy folder, to the 32GB USB drive vault, and the copy copied everything. The .System folder included.

Now, I’m not sure if this is a Windows 10 issue, or a shortcoming of the unhide special files view options, or a shortcoming of the right click, copy/paste, method of copying large groups of files, in folders, from one type of storage device to another.

I have managed to achieve the desired result.

I don’t believe this is/was a Sandisk issue, after all.

Thanks Ed, for your input.  

Hope this helps anyone else who might run into this issue. 


1 Like