Can't copy anything to the drive..???!! (SanDisk Cruzer Blade USB Flash Drive - 32 GB - USB 2.0 )

RE: SanDisk Cruzer Blade USB Flash Drive - 32 GB - USB 2.0

i just purchased this flash drive and am trying to copy a 4 GB file to it. no matter what i do, it will not work!! it goes thru the motions of working (taking approx 45 minutes), but then at the end, it says the copy failed. i’m running windows 7 on a dell optiplex 980 computer (with tons of ram).

i’m using the secure access vault manager v.2.0. i’ve downloaded and updated the software that come on the drive, but still nothing. i’ve encrypted the drive, but still nothing.i’ve tried to drag-n-drop…nothing. i’ve tried bypassing the secure access manager, and just using two windows to drag-n-drop…nothing. i’ve tried everything i can think of!!

what the heck?! :smirk_cat:

i’ve never spent so much time on something like this. usually you can just pop a flash drive onto a computer and drag and drop files to it, and your done! no messing with software, etc. what a hassle!!

help please!! :grumpycat:

a. FAT32 formatted drives can only hold files that are less than 4GB.  Reformat your drive as NTFS.

b. Do not copy your 4GB file to the SanDisk vault.  It will take forever.  Secure Access is an option not a requirement.  Copy your file to the drive using Windows Explorer.

There is a file size limitation of FAT32 (the format of the falsh drive). It does not support files 4GB or larger. It is not a fault of the drive itself; all flash drives are formatted as FAT32.

If you must use it for a single file of 4GB or larger, you will have to re-format your drive as NTFS.

Edit: I see great mind think alike . . . and at pretty close to the same time too. :stuck_out_tongue:

what? that’s crazy!

so a couple of questions:

  1. so this 4gb file is a zipped file of a bunch of other files/folders. will it hold the files/folders if i copy them as a group, but not as one, 4gb zipped file?

  2. is there any downside to formatting the drive as NTFS?

  3. how do you do that?

  4. will the secure encryption, etc. still work?

thanks. :smiley_cat:

fyi…i’m trying #1 above right now…seems to be working.

i’m not concerned about how long it taktes. these files/folders are my website files (i’m cancelling my web hosting). i downloaded them at work (faster internet) and want to take them home to put on my home computer. i perfer the secure access if possible, just in case i loose the drive…it’s little! and there is some pretty secure stuff in the files/folders.


The limitation is a single file. If you have a folder with lots of files that will work.

You can use secure access but it will take a long time to encrypt that much data.

that’s okay…i have the time. main thing is to get the information to my home computer.

thanks all! :catvery-happy:

Can’t copy anything to the drive…!!! (SanDisk Cruzer Blade USB Flash Drive - 32 GB - USB 2.0 )

I am having the same issue but I am on a Mac OS High Sierra version 10.13.6

I don’t know how to reformat this drive… What should or can I do?

Do I need to continually buy additional drives?

In advance, Thanks for the advice!

Are there files on the drive you can delete LH?  Easier and quicker than reformating.

Reformating will indeed delete everything on the drive so if there’s anything you want to keep you need to back them up.

Buying a new drive is an easy option.

It may be because of dynamic nature of your HDD. In ideal case it should be basic. Don’t try to convert it into basic coz u’ll lose ur data. Try fixing ur laptop or pc from which u have extracted this HDD. Then copy the material official website