Ultra Backup 64GB: How to restore files on public computer?


I recently bought a Sandisk Ultra Backup flash drive with 64GB capacity.

Removed U3, installed the software on my PC - everything worked fine.

Now, if I come to a public computer with my USB stick, I can not install the backup software.

So, how can I access my backed up, password-protected data stored on the USB stick on a computer that does not have the Sandisk backup software?

Thank you very much,


The USB device was designed to have the backup software run from the USB device.  You choose to take a different route and now you see the disadvantage of that path. 

If you can reinstall the U3 sw your problem will be solved, if not you will have to remove the password from the device before using it on machines other than yours. 

you do not need to reinstall u3. there is a standalone version of the backup software that you install on the usb drive. if this is what you done all you need to do is open the usb drive on the public computer and run the backup software. then you will have access to all your files. just remember the stand alone software is installed to the usb drive not the computer. 

here is the knowledge base article with the software and installation instructions. 



thank you so much, also for the direct link.

I tried your suggestion and it works great! This solved my problem, and I did not have to reinstall U3!

Thanks and all the best!


I have the opposite problem. Just bought a 64Gb drive, it HAS the “Ultra Backup” but is MISSING the U3 and the ONLY thing I do need is the U3.

Downloaded the U3 installer and it says my Ultra Backup isn’t a SabDisk product and can’t be installed.

So, I spent over $150 for a piece of crap that only does backups? Who gives a rat’s ass about backups? What I want is something that lets me stick it into ANY computer and use my browser without leaving traces.

My 8Gb Cruzer has been working flawlessly for about 3 years and this new piece of junk can’t do something my old stick has been doing since I bought it.

So, how do I install U3 on the “new and improved” 64Gb pen?