How to use the self backup function on a 8Gb Ultra Backup?

I’ve bought a 8Gb Ultra Backup Flash Drive and copied some documents inside. I tried to press the backup button on the Flash Drive, but nothing happened. (I’ve browsed from the windows explorer, nothing was seen for the backup)


Check your machine’s security logs to see if something is preventing the U3 app from running.

Hi Ed_P, I have the same problem. I tried your recommendation and disabled antivirus to be sure it does not affect starting of programs. I use Windows 7 and tried it on 2 different computers, on both the button is simply not working. I tried to follow the instruction to reinstall the software on the USB drive, as it is in the Support part of Sandisk page, but I did not have the choice to install the software to USB drive, it installed the software to PC only. Do you have any other ideas? Thank you Vaclav

On Win 7 64-bit machines you may have to run the USB app in Compatibility mode.  Try Vista SP2.

I’m not sure but I don’t think it will run from the PC.