U3 Application failed to install on SanDisk Ultra Backup 8GB

When I try to install U3 application on it, it failed in the end displaying error “Installation of u3 Launchpad failed. Try re-running this installer” although the CDROM drive has been created but U3 application fail to launch and also CDROM drive not opened when I double click on it. When I uninstalled U3 application with Launchpad removal tool, the Flash memory can be used as data backup only.  Kindly confirmed me whether my Flash Memory is U3 compatible or not although  the U3 software detects it as U3 compatible.

I already know that U3 has reached end of life but i want to fix this problem.

SanDisk Ultra Backup Product No: SDCZ40-008G -P36 


I really don’t understand why U3 has gotten its fame from having such errors. I have tried executing some files from my U3, although this maybe different from your exact problem, I have encountered as such that installation failure or something.

I don’t think the Ultra Backup used the normal version of U3 with Launchpad.  It started a backup app instead.  I think DrLucky posted a link to it once but I don’t know where.  You can try doing a search for it or hope that he stops by. 

Maybe this link can help?  http://kb.sandisk.com/app/answers/detail/a_id/5238

Or this one: http://kb.sandisk.com/app/answers/detail/a_id/4306/kw/Ultra%20Backup

I tried to find the posts of Drlucky, but could not find the relevant information. If the Flash Memory is not U3 compatible, then the U3 Launchpad application detect it as non-U3 device at the start of the installation, but this is not the case and the  U3 Launchpad application continue to install and Launchpad CD ROM Drive also appears but the instaltion fails at the end.

some ultra backup drives did have u3 when they were first launched. this was the last product to remove u3 on the sandisk product line. Since the VID and PID are the same the U3 installer thinks it can install however there have been firmware changes in the device which are not compatible with U3. as you know U3 is end of life and sandisk is pushing everyone away from it so installing U3 will not be an option for you. 

Has been established that can not be installed U3 application on new SanDisk Ultra Backup flash drive.

My question is: how to encrypt files to work on them directly from the device? As in the previous program U3?

At the moment I get a message that the files are stored in read-only. I can not work on these files.