Ultra 16 GB CF Card Unreadable

It appears that the subject card has failed at some point. I took a large number of photos with my 7D Mk 2 yesterday. I reviewed several during the shoot. I saw no problems. It’s not a new card, and it has worked fine in the past.

However, when I attrmpted to upload the images to my PC, it never brings up Autoplay, and when I attempt to view the images manually, nothing really happens.

Putting the card back into the camera returns an error message.

I tried the free version of Recuva, but it basically does nothing either.

Is there any recourse to recover the images from the card?


if the card is still somehow detected by the pc you can try to use the recommended software rescue pro in order to try to recover the files from the card.

if the card is not detected at all then you can find an it that knows how to recover the files directly from the chip of the card or contact a data recovery company to recover the files from the card.

at the end you can contact the sandisk support for a warranty replacement

At this point, it does not appear to be recognized by the PC properly. The USB 3.0 message does come on, since the card is in a USB 3.0 card reader  inserted into a USB 2.0 port. But now AutoPlay or manual properties  ever appear. Would it be worth it to buy the Recuva Pro? So far I just tried the free version, and it said it could not find anything.

If my camera would do it, what about reformatting the card, and then trying Recuva? Seems like I read that even if the card was reformatted, recovery programs can find missing photos.

By the way, thank you for the prompt reply.


if the test version could not find anything then i would not go to buy the full version because most probably it has to do with the recovery options and not the search of the files.

you can try rescue pro that is recommended by sandisk itself and see if this software can see the data

Thanks for the tip.