U3 or SecureAccess for Cruzer Titanium?

I’ve got three titanium USB drives: two 4GBs and one 8 GB.

I formerly had run U3 on all of them, but recently I received a compatibility error with W7, however this same stick worked on another machine running W7. Odd.

So I tried reinstalling U3, but no dice.

Then I find out about this SecurceAccess deal.

So my questions are:

  1. Does SecureAccess use encryption?

  2. Which is more secure?

  3. Are there any compatibility issues with the Cruzer Titanium drives?

Thanks in advance.

SanDisk, please get your compatibility worked out. This is a hot mess.

Compatibility is a Windows thing.  And it seems more so with the 64bit version.  There is also the situation of Windows’ handling of USB drives, assigning different devices to the same drive letter, even thought the devices are vastly different.

As to your questions:

  1. Yes, but to the files not the drive.

  2. IMO U3. It stops access to the drive rather than the files.

  3. No idea. 

Thanks, Ed. Can you elaborate more on the compatibility issue?

Since U3 is more secure, I’d like to proceed that route, but do I need to reinstall it on my USB drive(s) or update my W7 OS itself? Again, it worked on one machine running W7, but not on another.

Thanks again!

No need to reinstall anything, it works on a Win 7 machine.  The problem is the machine it doesn’t work on.  Check to see if it’s Win 7 is assigning the same drive letter to two different devices.  Check it’s AV log and see if the AV is stopping access to it.  Try different USB ports.  etc.