turns off after 15 seconds

my clip will play music for 15 seconds and then turn itself off, I just downloaded the updater and installed the firmware. It didnt seem to help. Is my player just dead? The battery has been fully charged.

Any help would be appreciated!

Thanks!

my advice is jump up and down on it then throw it in the bin. Then buy another brand name and never buy sandisk again.

 I have stopped using my clip and gone back to my small capacity (other brand) player.

I just could not get it to function in any reasonable way. This thing is full of bugs and reading through the forum is scary! I am not alone then. There is just too much crazy behaviour to tell about. I have tried formatting from the device itself, that did nothing, I then tried formatting from windows by rightclicking and chooseing format. That did nothing also.  When I do eventually get this thing to startup ALL the music is still there!  I wanted to try dragging the bin file of the new firmware into the root dir but I am not allowed, I get a “you do not have permission” and yes I am the Administrator so its not that.  I find this device totally unusable, I give up and will never buy Sansa again.

You’ve made this same point in a number of posts. I tried to make a response on one. Your language and attitude are not very helpful in resolving your supposed problem and the formatting issue makes no sense.

If you’ve completely given up on the product why bother to continue participating in the discussion.

I would try recharging it for a good, long time (at least overnight) and see if that helps.  It sounds like there is a power management issue going on.  And be sure to try a system reset (on switch held uppermost for 15-20 seconds).

If that doesn’t work, I’d contact SanDisk by phone for assistance.  And then, if needed, a warranty exchange (or return and exchange with your seller, if local to you and possible/easy).