Strange behavior-Think I have a bug

Hi, I bought my clip+ about a week ago. It is a 4 gb and I added 8gb sandisk micro card. I love that it’s so expandable. It’s been

working fine up until today. I decided to set the back light for 10 seconds instead of default 15 sec.  After about 15 sec  it turns itself off,

and then it will not turn back on.

 The only way to turn it back on (I tried holding power button on for 15 sec) is to hold power and

home. When I have it back on the player is back  on  15 second even though I confired for 10 sec.  I tried it a number of times with the backlight set for 10 seconds and the above

manifestations repeat. When it’s set for 15 seconds it works fine. I also

downloaded the firmware and it’s still doing the same thing. I also tried to reset it by holding the

power button for 20 secs. Didn’t fix problem. It’s not a big deal I can leave it on the 15sec  backlight but it makes me wonder what else might be wrong with it.  Do you have any suggestions? Thanks