I create a list of MP3 files in a Windows folder, and when I transfer them to my Sansa Clip+, the order as played is changed. Displaying the Sansa Clip+ content in Windows, shows the correct order. How do maintain the original track order as displayed by the Sansa Clip+ in play mode?

Your Clip+ reads and plays by the order of the ID3 tags, not the order you place them in. Even if you play them through the Folders option (under Music), they will play in alphabetical and/or numerical order.

The only way(s) to get them to play in the order you want is either edit the ID3 tags or create a playlist.