Playing album tracks in track order, not filename order?

When I try to play a whole album on my Sansa Clip+, with Music–>Albums–>[Album Title]–>[First Song], my Sansa plays the tracks in alphabetical order based on the file name of the song.  These are MP3s that have the track number in the <Track Number> tag on the file.  I assume that the Clip+ can read the file tags, since it has no trouble reading the <Artist> and <Album Title>.  So, I must be overlooking something obvious.  How do I get the Clip+ to sort by Track Number, not filename?  I have amost 4000 songs on the internal memory and the card, and I would hate to have to rename all these files with numbers in front of them!

Settings–>Music Options–>Shuffle is OFF, in case you were wondering.

My Clip+ plays the tracks as they appear on the album when navigating Music–>Albums–>[Album Title]–>[First Song].  Try to retag the MP3s.  I use http://www.mp3tag.de/en/  and I have never had any problems.

Thanks for your suggestion! 

Examining the situation further, it seems that some of my albums do play in track order while others don’t.  I guess the Sansa Clip+ can only read track information if it’s encoded a certain way?