The Sansa Clip - Power Button

I think i have a similar problem to most of the people on this website, i have a blue sansa clip (2GB) and the other day the girlfriend was listening to it, however, she turned it off like normal but nevertheless i wanted to use it the next day, when i came around to trying to turn it on, but it wouldn’t accept it.

I have tried all the options available about resetting it, and also i have updated the firmware version as i was able to get access to it using the HOLD + Middle Button Option whilst connected via USB cable. However, now that ive done this, im able to see the sansa clip as a connected item on the ‘My Computer’ list. Everything that i had on there had now been deleted. So its back at factory settings. 

However when i have the device connected to the computer and i go to turn it off whilst its still connected, i can, and when i come to turn it back on again, it will turn on.

Its when i have the device disconnected from the computer and try the power button alone, it just won’t have it, it won’t turn on and i thought that it might be something to do with me dropping it, which, if i did, i can’t remember becuase i normally keep it in a safe place as i regard my mp3 player as my baby… lol.

Anyway, hope you guys have some suggestions as i am totally clueless…

please get back to me ASAP




Have you read the other threads on this same subject? If you can’t get it to power on, you may need to get a different one, either by exchanging it where you bought it, or by having it replaced through SanDisk’s warranty.

As far as all your music being gone, I doubt it. More likely is that during your firmware upgrade, your device defaulted back to the opposite USB mode than you used to put the music on with. If you put music on in MSC mode, it will not show in MTP mode, and vice-versa. It’s still there, but your computer will only ‘see’ it in the mode that it was transferred in.

Ahh, thanks for the fast reply :slight_smile:

Yeah your probably right about that one, but its ok about the music becuase i got it all saved on the computer, i just wanted to know why it had gone? as it might have ‘crashed’ and just deleted everything.

I would take it back to morrisons where i got it from in the UK, but they have stopped selling them -_-", i think they got alot of returns of this item so i will have to take your word on this and get in touch with customer support technicians…

Thankyou again


Do you have the European Telephone number for Customer Support?  

Message Edited by Scare on 10-16-2008 04:27 PM

If you’re in the UK, this should work for you . . .

UK (English)
1(44) 207-3654-193
9am - 6pm local UK time

I rang the number, but now its asking me for my account number? :S

got the number working, talking to some indian…

Must have been a looong phone call! Hope it was toll-free. :smileyvery-happy:

I think…I have the same problem as you…but it’s kinda different? (and I don’t know how to make a thread…-_-ll)((I’m a newbie???)

Well, it was working fine, but the power wouldn’t turn on so I thought, maybe I ran out of power???

So I plugged it into and AC adapter, but it didn’t charge, the screen was blank.

After that, I tried it on my other two adapters but it wouldn’t show up there also.

I connected it to my computer and the display still wouldn’t appear.

I held the button up for 15 sec., and w/ the middle button too…

PLEASE!!! I need help.! And I thank you in advance…