"synchronize to continue your music subscription" + another problem I think

Ok from browsing these forums a bit I have found that I need to Update My Track Licenses in order to use them and possibly get rid of the “synchronize to continue your music subscription” problem. The thing is before doing that I followed the advice of another and synchroized the tracks I have with WMP11 and now they’re wma which I believe are suppose to be mp3 (can’t seem to remember the type even though I’ve seen it many times). And it seems like the Sansa SanDisk Clip (4GB) can’t play wma. So how can I make these files which I downloaded while under the 30day subscription go from wma back to mp3?

Tracks downloaded from Rhapsody are windows media audio at 160kb/s.  The Sansa Clip will play wma, mp3, ogg, flac, and Audible aa formats.  You can use constant- or variable- bit rates too.

Rhapsody uses wma format because the tracks are wma DRM files for the subscription music.  These files will play as long as you subscribe.  To have mp3 unprotected media, the tracks need to be purchased.  The rights holders on this music would be mad at Rhapsody if the music was being distributed for free.

There’s also the option of downloading the music at 256 kb/s MP3 (you can specify the format and bitrate desired for your purchases from Rhapsody.  They have been moving to the 256 kb/s format for purchases, without DRM.

I like using 160 and 192 kb/s for rips from CD.  The files aren’t too big, and wma sounds good on the go.

Bob  :smileyvery-happy:

But how can I listen to the music I downloaded during the free trial? Everything was going fine till the trial ran out and now I keep getting “synchronize to continue your music subscription.” Will I have to delete all the songs off the Sansa SanDisk and put music on it without the subscription requirement?  I tried to do as advised somewhere along the lines of: plugging in the device and going to manage and then doing Update Track License but it still keeps telling me to what I believe is to resubscribe.

If you dont want to resubscribe, you will need to get the files you got with said subscription some other way. Perhaps buying the track from Amazon or a place like that. Its your call if you want to use the likes of limewire or something like that.

ah ok I get it

OK, two problems that may or may not be interrelated and the 2nd one applies specifically to this thread.  

Problem 1 (discovered first):

Caveat: I have had no issues transferring tracks to my device (to date), I am using Rhapsody to transfer songs to my Fuze, I am running Windows XP, and my account is the “To Go” service and I’m fully “paid up”. 

Yesterday I plugged in my Sansa Fuze 8GB (with 8GB HDSD Card) and tried to transfer an album to my Sansa.  All 12 tracks errored out with the message, “error, insufficient rights”. 

I received this error message before when I tried to upload songs to my girlfriend’s brand new Sansa (exact same model/capacity as mine) and because it only had the factory pre-loaded songs on it, I simply deleted them and then re-attempted to load the album that was giving me the the error message.  Wa-la, problem solved.  

Unfortunately, the same course of action with my player is not an option.  I am mobilizing at Ft. Sill, OK and I am connected to a wireless B router, and because I have 1500 tracks on MY player, deleting my entire catalogue and re-loading it is definitely my LAST option (and not really an option at all).  What’s the deal?

Some of the trouble-shooting steps that I took that DIDN’T include erasing my entire catalogue (that I spent an immense amount of time prioritizing and downloading specifically FOR this deployment and my impending year in theater without reliable and/or high speed internet) include:

Adjusting the time on my computer to match the device (I went from EST to CMT when I left Ohio for Oklahoma).

Adjusting the time on my device to match my computer.

Problem 2 (related to this thread and my 1st priority for problem resolution)

Caveat:  Apparently, since arriving at Ft. Sill I have sync’d my device at least once - merely by connecting it to my computer with Rhapsody running (as I always did previously and successfully at home).  When I select my device to display all the songs on it, in the bottom right hand corner of the Rhapsody screen it displays “Licensed until 2/10/2009” and today is 2 FEB 09.  *Update*:  My computer clock just rolled over to 12:00 am (midnight) and now it reads "Licensed until 2/11/2009.  Eight days??  Also, when disconnected my device displays the “green dot” that represents a “freshly” sync’d device.

I keep getting the same “synchronize your music subscription” error message when trying to play songs.  Troubleshooting that I have done thus far:

Right-clicked on both the Sansa 8GB - Internal Memory icon and Sansa 8GB - External uSD Card and selected “license”.   Everytime I do this it tells me at the bottom of my Rhapsody player that “Internal Memory Licensed Successfully”.  Not wanting to disconnect and re-connect my device just yet (it takes what seems like days to recognize all the tracks on my device), I tried every other conceivable option:

I tried selecting all the tracks in an attempt to right-click and “synch”.  Of course, this option is not available.

I de-authorized my device and re-authorized it.   

I tried downloading another track to the device (see problem 1)

Went into Tools > Preferences > Devices > Advanced Settings (one of the suggested fixes provided by Rhapsody when I clicked the “?” when my tracks wouldn’t transfer) and deleted the cached files

Went to My Account > Update Track Licenses and the dialogue box told me it was renewing track licenses for songs on my computer.  It then told me “renewal complete”.  

Also, I’ve noticed that when I used to plug my Fuze into my computer at home, because I have added “Channels” to my player, it would update those channels with new songs automatically.  Since arriving at Ft. Sill and connecting to the B router (should be immaterial) my player no longer “updates” my channels automatically (as it once did).  Additionally, if I try to add new channels to my device it simply will not do it.  

In any event, hopefully I’ve supplied enough information to solicite some quality advice on how to 1) Synchronize my device (number one priority - I need music for the gym!) and 2) add tracks to my device without getting the “insufficient rights” error message.

Please help!



Another couple of steps.

Deauthorize the device, deauthorize the computer. Reauthorise the computer and then reauthorize the device.

Next, reinstall Rhapsody on the computer.

It this fails, I think you should reformat your Fuze device using the devices format command. This will correct any Corrupted DRM license store.

Try transferring a single track to the Fuze. If that works, you can then start resyncing Channels and content to the device again.

There’s a limitation caused by the WMDRM (Windows Media DRM) used by any Plays For Sure device: the license is twofold, meaning that both the device, and the host computer, share the license.

Individual tracks have what’s known as a leaf license embedded into each track.  As Rhapsody scans your tracks, what it’s doing is renewing these licenses.  SanDisk has updated the firmware for your Fuze recently, accelerating the process a bit.

You mentioned a lagging license date when the Sansa is plugged in to the Rhapsody 4 client.  Rhapsody allows three computers and three devices for each account, but there’s a caveat:  though you can synchronize your tracks and load on any one of those PCs, Microsoft built a wee problem into the PFS DRM system.

The license on any tracks from one PC have to be resynchronized from that same PC, or they will expire.  Thus, with Rhapsody or any service using WMDRM, all is well as long as you load the tracks from one PC per device.  Or, you’ll have to synchronize with both PCs to get those wee leaf licenses in step.

Note that the Rhapsody Channels would not automatically refresh.  This problem has given me fits, as well as the displayed date for the last channels refresh.  It is possible that the client will only reload the Channels from the original PC.  You can force the update by pressing the Transfer button when the Channels list is selected for your connected Sansa.

I’ve gotten into the habit of clearing a device, and reloading the same tracks from the Rhapsody account (personal) library from the PC that I’ll be using regularly.

Bob  :smileyvery-happy:

I have a e250 and I am having the same problem as Musik777, the songs I downloaded from Sympatico MSN Music store are all giving me a “Sychronize to continue your music subscription…” If I buy the track from Amazon, does that mean I can keep it on my mp3 forever???

I"m a newbie at mp3 players, so forgive my lack of techie know-how!


With WMDRM, as long as you synchronize the file between the host PC and your Sansa, the song will play.  The transfer must be made in MTP mode.

Amazon, Rhapsody, and others have been migrating to unprotected MP3 for purchases, freeing you from DRM issues.

These files can be transferred in either mode.  The industry is realizing that pirated media will happen regardless of attempts to thwart it, and DRM often hurts only those who are being honest by purchasing the media.

Bob  :smileyvery-happy:

Dear Neurtron bob,

I am a newbie at mp3 players so forgive my ignorance…what do you mean by MTP mode? I have all my songs stored in my windows media player and can play them but the ones whose subscription ran out can’t be synched back to my Sansa…I’ve tried that many times.

What else do you recomend or will I have to buy them again? 


On the device, go to Settings > USB Mode > MTP.  This mode is needed for the host computer to see the Clip as a media device, and to transfer DRM encoded files.

If you’ve never changed it, the default setting on the Clip is Auto Detect.  In this mode, if the operating system of the computer will support an MTP connection, the player will select this mode.

Your music, if it is DRM encoded, should easily retransfer, or you can synchronize the music using Windows Media Player, or a separate client like Rhapsody and Napster use.

If you are suddenly getting the “synchronize” message on your Clip, it’s entirely possible that the DRM license cache is messed up, or the device can use a firmware update.  I had random “synchronize” issues with the earlier firmware revisions.  SanDisk has addressed this in the latest firmware.

Rereading your last post, there’s a similar issue with the Rhapsody service for subscription tracks.  If you open WiMP, and look at the suspected tracks in the songs or album list, if you try to play the tracks, a blue “i” will appear nect to the track, warning that media rights are missing.

In this case, all one needs to do is open the Rhapsody client, and select “update track licenses”.  After a few seconds, if one reopens WiMP, the tracks will all play.

Check into your troublesome tracks, and check the provider’s information regarding media rights.  If the tracks were “subscription media”, renewing your membership will restore playback.  If they’re purchased tracks, we need to see where they were sourced from, and then we can go from there.

Bob  :smileyvery-happy:

I changed the setting to MTP and tried to synch the songs to my Sansa but it didn’t work but I am getting the blue “i” beside the songs I want. when I click on them, I have the option of “synching this file” or “synch previously skipped files.” Should I be doing either? I don’t know if this makes any difference, but I purchased the songs from the MSN music store, so I’m not sure if its a subscription or what. I thought that I was buying the songs, not subscribing to anything.

You mentioned Rhapsody–what is that?


I posted this in another thread, but I think this is the thread it needs to be in.

I have purchased my songs from rhapsody, and I’m getting this messege.  I’m really new to mp3 players.  This is my 1st 1, but I have purchased and downloaded music to cd’s before.  I don’t know why i’m getting this messege when I have paid for my music.  Any help please.

I just realized that I’ve been posting to the incorrect device forum–I have a e250 “Lil’ Monsta” not a Sansa Clip. Oops…:womantongue: