WMA problems

I have an e280 with the latest firmware upgrade. XP with latest updates. I purchased tracks from both Rhapsody and Walmart, all WMA format. 4 tracks total. Transferred them from my PC to Sansa with Rhapsody software, then tried MS Media Player 10 then upgraded to version 11. Also did a direct transfer using Windows Explorer. In every case when I try to play the tracks on the Sansa I get a red pop-up stating “Synchronize to continue your music subscription”. Then the Sansa jumps back to the ‘Music’ menu icon. Ripped tracks from my purchased CD’s play fine. The tech support people at Rhapsody were no help. I like the selection but the problems and lack of tech support forced me to cancel my trial subscription. Thanks in advance for any help.

I take it this is an e280R becuase the R series of playes support Rhapsody’s DRM Helix. Also I am pretty sure you have to sync the Rhapsody songs using the Rhapsody software.

Message Edited by Narse on 07-25-2007 08:48 AM

The ones we got from Rhapsody with the trial arent gonna work no matter what is done. Once you cancelled out with them, the licenses on those files cant be re-newed.

The ones you got from Wal-mart, do they play on the computer just fine? Are you using Windows Media Player 10 or 11?

None of the tracks I purchased from Rhapsody would play on my Sansa even when my subscription was active. (my membership is still active until the next billing cycle) They will play on my PC with the Rhapsody player. I purchased my Sansa new from Amazon this month. The box and instruction book identify it as an e280. The back case of the Sansa is labeled ‘Sansa’ and bellow that is printed ‘Rhapsody’ with the Rhapsody logo. Nothing on the Sansa or the paperwork to indicate it’s a 280r. No, the Walmart tracks will not play on the Sansa. Same error message pop-up on the e280 as with the Rhapsody tracks. I did play and sync the Rhapsody tracks with the Rhapsody player program. I am using Windows Media player 11. It’s a great player otherwise. The only problem being with tracks purchased online.


I would suggest to format the player in MSC mode and on Disk Manage Management for a low level format. After you formatted the player in Disk Management, switch it back to MTP mode and try to synch songs again from Rhapsody.:robotwink:

What you can try for you Wal-Mart issue, sign into Wal-Mart through WMP, through the online stores, and then update the track licenses. That should fix your Wal-Mart issue. I had to do that once.

Make sure your player is on Rhapsody mode, and then try updating the track licenses? That might help.

But that could fix your wal mart issue though, because it happened to me.

Message Edited by Peter_Griffin on 07-26-2007 12:43 PM

I’m using WMP 11. The Walmart files play fine on the PC but I get the same “Synchronize to continue your music subscription” error pop-up with them as I get with the Rhapsody tracks when I try to play them on my Sansa. Also I tried to format the Sansa with Rhapsody program. It performed the format and I got the message to reconnect the Sansa. However when I reconnected there were no changes. All the content was still on the Sansa. Tracks, videos; everything. Also as one group member recommended when I check the USB mode it does list ‘USB MODE’ not just ‘MODE’ as an e28r would so I take it I have the non Rhapsody Sansa version. A bit frustrating as the Sansa does everything else so well. I can do without the subscription stuff but it would be nice to be able enjoy the full functionality of the Sansa if I ever decide to try another music service. I only purchased a few tracks.

I am now too having trouble with the “Synchronize to continue your music subscription” notice with the songs that I downloaded from Wal Mart’s site.  You wrote about track licenses, but when I sign in through WMP, I don’t see an option to update the track licenses.  I would appreciate any and all help so that I can listen to the songs I bought again.

I am having the same problems.  I have spent time emailing and speaking with Sansa reps on the phone and they have provided no solutions.  Other than format, re-load, re-sync, etc - all a waste of time.  Has anyone figured this one out?  I have formatted the device, switched between MSC and MTP, tried Windows Media 11 and Rhapsody, all to no avail.  I have purchased all my tracks from Walmart which evidently are WMA with DRM.  The tracks play fine in Windows Media Player 11 and Rhapsody.  Help?? I have the e260.