Stuck Pixel?

Hi, I just bought a Fuze 4GB black from Amazon and when i look at the screen, I see a few dots that are different color than the rest of the background. I wonder if they are some dead pixels.

If so, should I return it and get another one?

This is a common problem in LCD flat panel computer monitors, etc. so I suppose it’s also possible with the Sansa’s LCD screen. The Dell monitor I looking at right now has 2 dead pixels; 1 shows red, the other blue. You can’t see them all the time, just when the screen is dark. It’s been like this from Day 1. I contactd Dell about it and the issue was SO common they actually had a policy on it. Anything less that 6 (IIRC) was considered “within tolerences” and therefore NOT a valid warranty claim.

Still, those 1 or 2 colored pin-dots staring at you is aggravating, but like I said I can’t see them most of the time. I can’t say as I’ve heard this complaint on any of the Sansas, but as they all have an LCD screen on them (what today doesn’t?), it’s certainly possible these would be as vunerable to this malady as any thing else.

Are these dots “stationary”? In other words, can you see them in the same place on different screens and menus on your Fuze? If so, then I’d say, “Yes”, they sound like dead pixels and “Yes” I certainly would return it for another. Amazon is usually very good about customer service & returns so I doubt you’ll have any problem whatsoever.

Besides, I hear WOOT’s inventory level has dropped and they could use your device so they can keep their sales up! :smileyvery-happy:

After a little research on the internet, I found out that “dead pixels” are either black or white. The dots on my screen is like… some sort of glitter on it that won’t come off no matter how i scratch, wipe, or clean it. They change color from different angles.

So, are they stuck pixels or what?

Edit: And, they are only visible when the background is blue, I can’t see them while viewing the photos that came with Fuze. If I have to count them, I’d say about 30 scattered around.

Message Edited by TamamaEX on 07-31-2008 04:33 PM

@tamamaex wrote:

 

. . . If I have to count them, I’d say about 30 scattered around.

 

“Hello, Amazon?”

@tamamaex wrote:

After a little research on the internet, I found out that “dead pixels” are either black or white. The dots on my screen is like… some sort of glitter on it that won’t come off no matter how i scratch, wipe, or clean it. They change color from different angles.

So, are they stuck pixels or what?

 

Edit: And, they are only visible when the background is blue, I can’t see them while viewing the photos that came with Fuze. If I have to count them, I’d say about 30 scattered around.

Message Edited by TamamaEX on 07-31-2008 04:33 PM

Try putting a blue image (made with paint, photoshop or whatever photo editor you might have) as a photo on the player to test whether the pixels show up in photo mode.  Try to match the blue in your image to the background blue as close as you can.  If they don’t show up as defective when viewing your blue photo, it could be the issue is something other than the LCD screen itself.  A firmware update might solve it if that’s the case.

I already have the newest firmware, but anyway, thank you. I’ve already sent it back to Amazon and my new player should arrive tomorrow. :smiley:

You have dust under your screen, they’re not stuck/dead pixels.

So that’s why, I have noticed that when I press the right hand side of the screen, it makes a noise as if it’s not completely closed. I don’t think that is completely sealed, so that’s how the dust got in…

Oh, I think i have got one too :frowning:

Would you recommend to send it back, or do you think thats “ok”?

I am quite disappointed now :frowning:

 All the time i stare at it…

Or can i fix it somehow?

I just can see it, when I look at the player from a specific angel…

Here s the pic.

Message Edited by Quanty on 11-22-2008 02:18 PM

I am on my fourth Fuze (black 8gb) with stuck/dead pixels (or dust under the screen). Needless to say that I am not thrilled.

I believe you are looking at not something wrong with the LCD, but something wrong with the plastic shell over the LCD. The pixel shouldn’t change colours at different angles. This can only be explained by a deformity in the shell. I had a dot like this too on my first fuze. Try spraying a tiny drop of water on your monitor. You should see the same effect. Just a deformity in the optics of the surface.

It definitely looks like it is under the shell, when you look at it at an angle.  But either way, it is a defect.  They are RMA-ing these also, so the support is great, it just stinks that my daughter still cannot enjoy her Christmas present.