Stuck on Refreshing media screen & now won't mount on windows 8


having real trouble with my Sansa Clip which i hope can be fixed because at the moment it’s unusable and i really like my mp3 player :frowning:

Problems in breif:

Conntecing to a Mac resulted in error “not enough space for muisc DB”
This was overcome by continually pressing the square button on start up.

A while later i connected to a different mac ( big mistake!) resulted in error “Refreshing meda”
Which it doesnt, it just freezes on that screen. 

I am now unable to mount it on any machine mac or pc… on connecting to the computer it freezes on  "not enough space for muisc DB screen.

Can someone tell me how to fix this?

I’d like to be able to mount my sansa clip on a windows 8 machine,

Ideally i don’t want to reformat and would love a way to fix it without doing that but at the least if i can connect to a machine, copy all my music off then reformat that would be great.

Advice would be great

Thanks!! x

You don’t have backup copies of your music? I advise people to keep a few backup copies of their mp3 files, even if they have the original CDs for all the music. Reripping hundreds or perhaps thousands? of CDs would be very annoying and time consuming. 

If there is a card in the player, I suggest removing it while the player is off, then try reconnecting again. 

If you could find files on the player that have bad tags or are corrupted, you could try deleting them off the player if you can get the player to boot up.

Freezing while refreshing the media is using due to bad or incompatible tags. Apparantly the mac default is to write mp3 tags as ID3V2.4 while the Sandisk players need ID3V2.3 ISO8859-1 tags.

Thank for the reply.

I can’t mount the player on a computer, so i can’t access any files.

How do i get it to mount?


If you can get the player booted, you could delete files one at a time on the player itself.

I can’t boot the player and i can’t mount it.

Any more suggestions? 


Did you try holding down the power button for over 30 seconds, until it boots up? holding down the power button for over 30 seconds resets the player.

If you can get it to boot up, I suggest formatting it ASAP using the player’s menu-setting, system settings, format.

After that, make sure the usb mode on the player is set to MSC-settings, system settings, usb mode, MSC. 

If your music is mp3 files, make sure the tags are ID3V2.3 ISO8859-1. The default for the mac is ID3V2.4, so use itunes to convert the tags to ID3V2.3 ISO8859-1. The Clip+ doesn’t support AAC files(unless you install the alternative firmware(operating system for the player) Rockbox).


No nothing worked.

I turn on the player if its been reset it goes to" not enough space" error screen then shuts off

If i then press the big square button while it’s on the “not enough space” error screen it goes onto the refreshing your media error then freezes

Any more advice?


If there is a card in the player, did you try removing it while the player was off? 

Was the USB mode on the player set to MSC?

Did you try holding down the center button on the player while connecting it to the pc? This forces MSC mode.

No card in the player.

Mode was the other mode not MSC

Have tried holding centre button when i connect to a pc but nothing happens… How would i know if the device was recognised on windows 8


You could try searching these forums for more ideas.

I never used Windows 8.

The Not Enough Space message comes up if there are problems with the memory. By default, Mac formats discs differently than Windows does. By reconnecting to so many different computers you may have made the memory completely unreadable.  

But try some last-ditch methods:

Seeing if it connects in Windows 8 is the same as previous Windows.  You just have to use the old Windows interface (PC Desktop) rather than stupid Apps/tablet mode.

Here’s how:

Once you get the PC Desktop, click through the Windows Explorer icon on the bottom left–the beige thing with the blue handle–and click on Computer. Connect the USB, hold down the REWIND (<<)  button–not the center button–and connect the Sansa and see if it pops up as as Sansa Clip and Removable Disk drives. If << doesn’t work, try center again. 

The problem is, that’s the MSC connection and if you were using MTP your music is going to be invisible (though click around inside just in case).  

And if, miraculously, the << connection works, Windows may just possibly–not holding out much hope but possibly–be able to fix memory problems. Here’s how to use CHKDSK in Windows 8—boy, have they made it complicated.

If you’ve still got an older PC around, you can just double-click the Sansa icon, Tools, Check disk. 

If you do get it back with CHKDSK, and you’re sure you were using MTP, switch the mode to MTP, connect to a Windows computer and back up your music. After that, I’d suggest switching to MSC and never, ever letting Mac do anything automatic like synching. 

In MSC mode, the mode which will also allow it to connect to a mac, the player will appear as two external drives, one for the player internal memory, and one for the card slot. Holding down the center button while connecting forces MSC mode. MTP mode needs a PC with Windows Media Player installed to connect. It must also be a relatively recent version of WMP. 

I have sometimes had trouble when switching between my usual MSC and trying MTP (sometimes to answer a question here). A couple of times I have needed to format after trying MTP.  Then throwing two different Macs into the mix is a real wildcard.

I hope the MSC connection and CHDSK work, but it’s a longshot.

It might be worth calling 1-866-SANDISK, too. 

Did you ever get this going?

I have the exact same problem.  

I’ve tried holding the center button while plugging into a MacBook.  Nothing.  I’ve tried holding the << button while plugging into a Windows 7 machine.  Nothing.  I’ve tried running the battery down and every combination of buttons I can think of.  Still, it won’t get recognized by any computer.

Seems like really bad design that 1) music is kept in two different places, depending on what USB mode/computer you’re connected with and 2) if you’re in the wrong USB mode for the computer you’re plugging into it can essentially fry the device.