Stuck in foreign language

Less than an hour old, the clip powers up in

a foreign language. Manual said to go to Menu - settings - language

and select appropriate language. I can figure out the settings icon, but

I can “read” the language in order to figure out how to select “English”

Please help or it goes back to the store. Thanks!

In the “settings” menu, go down 4 times and you are on the “Language” section.

I appreciate the advice! Called support and the tech, Dave, and I tried for 30 minutes to figure out how to get it from Koran (or whatever) back to English. If shipped in a different language, the menu arrangement is also diffierent.

Finally took it back to the store, the girl at the counter told me it was easy to switch to English, she took the unit, tried for 4 minutes, dropped the unit on the showroom concrete floor and told me to just go get another from the rack. Problem solved. :>)

My new clip is stuck in a foreign language as well. I tried the 4 down on the settings menu, but I can see an FM on that line. Any further suggestions/instructions?

I have to say that the clip has the least documentation and instructions of any electronic devive I have ever seen. Even the “users guide” available on the website is sparse. I really think I will like the clip if I ever can get it back to english.

EDIT: I updated the firmware and the clip was reset to English. Problem solved.

Message Edited by smalc on 12-13-2007 09:58 AM

Hi All,

In order to change your language back to English or whichever language you prefer.  Please go to Settings (which is the icon with 4 bars & 2 bars are moving up & down)…select Settings to go to submenu, then scroll down until you see FM xxx, then the line above FM xxx should be your language menu.  Select it and it will bring you to the list of the language and you should be able to choose your preferred language again.  Hope this helps

I just got a new Sansa clip and it is also stuck in a foreign language.  I was able to find the settings menu, but when I went to the submenu above the FM one, it only had one option.  Any ideas?

Update:  I just updated the firmware, and this fixed the problem. 

I was scrolling through the languages to see what all there were before setting it to English and I somehow hit the button to set the language prematurely.

I have this model: 

SDMX18R-008GK-A57

I tried following te instructions but they don’t seem to pertain to my model. It says select settings. There’s only one item which I assume is settings.  But then I don’t see FM anywhere.

I also tried updating the firmware but its still in Arabic or whatever language that is. Maybe if I removed the battery and put it back in?

Edit: I know I have a Clip+ model but Google brought me here. Sorry.

Edit2: I found FM but the rest of the instructions didn’t work. I read somewhere else that the menus are arranged differently depending on the language. If that is the case then those instructions wouldn’t be very useful.

My logical brain tells me to go through every menu and ever submenu until I find the language menu. But I’m afraid I’ll screw up other settings doing that. I’ve already done it that a little and inadvertantly changed some settings I think.

I was also trying to do the old pocket video game(and some digital watches) trick which is pressing all the buttons at the same time to reset everything(or it just causes every part of the display to be active).  But I’m having a hard time getting a finger on all the buttons. I actually got the language menu to briefly appear during one of my attempts.

Message Edited by heat84 on 01-13-2010 08:52 PM

Message Edited by heat84 on 01-14-2010 05:13 AM

Message Edited by heat84 on 01-14-2010 05:13 AM

Message Edited by heat84 on 01-14-2010 05:14 AM

I fixed using the pocket video game trick! With it off, I held all the buttons except the power button and then pressed the power button. When it came on, there was a Diagnosis menu item (along with the others that were still in the foreign language). I went in to it and it was the settings in English. I went into the language settings and it was already set to English. I turned the player off then on again and it asked me to select the language again so I did and now its fixed.

It could be that its not necessary to hold all the buttons to get into “Diagnosis” mode. Maybe I’ll investigate that further. Or a SanDisk employee could just tell us the necessary buttons(Since I’m in Area 51, you might as well show me the UFO’s:stuck_out_tongue: ).

Message Edited by heat84 on 01-14-2010 06:30 AM

Same thing here.  I updated the firmware (this link: http://kb.sandisk.com/app/answers/detail/a_id/300 ) and restarted.  I then clicked to the settings icon on the clip (the one with the four bars and the sliders moving up and down) and clicked down until I read “English.”  Press the center button a couple of times as it sets you up as English as your choice.  Then I could read the titles to the menus and play what I wanted.  Hope it helps.