Language settings


My problem is that my Sansa clip has been set to another language.

I read the userguide and know the order to set it right


  1. Press Menu button to return to the Main Menu.
  2. Move to Settings and select it.
  3. Select Language.
  4. Select a desired language.

But since I can’t read the language which is the “Language” tab?

Thank you in advance. 

Someone more experienced might be able to help you solve this quickly, but if no one does, why don’t you try reproducing the language in Babelfish and see what translation is? Or, if you can reproduce the list in the language you don’t know here, maybe one of us can identify it for you. I work with an international community and can ask someone to help if we need them.

If you reapply the firmware manually, the language will be reset, I believe.

Reapplying firmware requires me to select Save which I won’t be able to find.

The easiest solution I was hoping was someone with Sansa Clip also

who can tell me how many times to press down or up to get to Language

after that I should be able to try and figure out which is what language. 

langauge is normally the 4th “tab” down.  Also you could enter each node, and scroll to see if there are other languages present. if not than hit back or menu and try the next node. The order for settings is as follows:





FM Settings


System Info

Reset All


USB Mode

Press and Hold 

Thanks Toma, that just saved me.

Now if I could only get my other Clip charged so I can program it… 

Thank you thoma for the list.

FM appears in every language that I have seen on the Clip, so I look for FM then go up one selection to go to Language.

Then I click up a few times. If the language changes, eventually you will get to English.