Streaming audio from FUZE (external card) to pc, stopped working.


I have a Fuze v1 and use only the external memory slot to store audio. In the past i could plug the Fuze into the PC and just explore the memory and listen to any of the music. After i updated to that latest firmware, it now wants to copy the audio before playing. This means that i must wait for ages (if its a 90 min mix) to hear it. This become a real pain if i want to flick between files. It has also made navigating the Fuze more annoying by adding some “MSC” folder that wasn’t there before. I have reverted to the older firmware and reset to default settings but it’s still doing the same thing.

Anybody offering any insight/help would be much appreciated.

Cheers, J

Neither new nor old firmware requires copying music back to your PC. That would be nuts. The problem is either in your computer’s music-player software or in the USB mode on the Fuze.

The firmware upgrade may have switched your USB mode. Go to Settings/System Settings/USB Mode and change it. There are actually two modes, MSC and MTP.  (Auto Detect chooses between them, often incorrectly.) Try both MTP and MSC to see if you can get the old behavior back. 

MSC makes your Fuze work like a basic storage drive. You just drag and drop music onto it via Windows Explorer.

MTP has it controlled by Windows Media Player. You send the music through Windows Media Player, sync, do playlists, etc.

It sounds like you were using MTP before, but it’s hard to say without knowing what kind of media player is on your computer.

The fun part is that your computer can only see one USB mode at a time–each mode appears to your computer (but not to the Fuze itself) as a separate partition. If you sent files via MTP, it will only see those files. If you sent them via MSC, then the MTP connnection won’t see those files. Again, it depends on how you were using the Fuze before the firmware change. .

If you are still getting weirdness, what is your music player on your computer? Try a different one, like Winamp or Media Monkey.

Hi, thanks for the reply. Yes it seems it was set to MTP. I use VLC player almost exclusively and just drag-n-drop files. I have never made play-lists or antthing like that. I just keep it simple.

Cheers, J

thanks for sharing, some audio files are drm protected , this make them difficult to stream on some players. if so, maybe you can trystreaming audio converter for mac to convert them to other popular format of audio files.