Strange new problem with Rhapsody to go on my Sansa Fuze

Have an 8gb Fuze with 8GB micro SD card inside and have been using with Rhapsody for a long time without any problems. Recently, I had not synced in a while and got the message that to listen to my subscription tracks, I need to sync with Rhapsody. So I figure, no problem, and I do so. The sync works fine and I get the message in Rhapsody that it is reading the tracks on my Sansa and I get the message that it is updating the internal memory on my Sansa. Then all is completed and when I click on either internal or external memory in Rhapsody, I get the message that everything is fine and it sees all tracks on my Sansa just fine. I even put a couple of new albums from Rhapsody onto the SD card in my Sansa. Again, no problems.

BUT when I disconnect the Sansa (again, normal behaviour with the green bar on the Sansa screen and message that it is refreshing my media), it still says that I need to sync to listen to my subscription tracks.

Have tried resetting the sansa, have tried licensing the sansa while connected to rhapsody, but nothing seems to fix this. How can I  fix this???   Thanks so much for your help

Try to update the license again. Make sure the Fuze is connected under MTP mode first. Go to My Account on top of Rhapsody and click on “Update Track Licenses” then, Hold CTRL + SHIFT and right click on your Sansa on the left pane and select “License”. If still does not work, unfortunately you would have to format the player and reload the tracks.

I tried your suggestion, but it didn’t work. The problem is bizzarre. I can load new tracks onto the device and when it’s connected to Rhapsody, everything looks like it is working fine. Formatting it and starting over again is a pretty major drag as I need to reload 14GB of music. Welcome any other suggestions…?!

Whose fault is glitchy BS like this?? Rhapsody or SanDisk?? 

The Rhapsody client can be a little confusing.  As long as the Fuze is connected in MTP mode: look at the sources pane on the left (Rhapsody 4 client).  Does the Fuze list in capital and small letters as Sansa Fuze 4GB for example?  If so, you’re in the correct mode.

And now for something completely different.  Deauthorize the Fuze via a right click on the device, then Authorize it again.

The License button has been problematic for the last two years at the least.  The deauthorize / reauthorize process works the best.  To verify operation, go ahead and transfer one new track.

Bob  :smileyvery-happy:

Neutron_Bob: Thanks very much for your suggestion. Unfortunately, it didn’t fix the problem. When I deauthorized my Sansa, it clearly worked and showed it was deauthorized and prompted me to authorize it. When I authorized it, it reported that was successful and I was then able to transfer a subscription track over from Rhapsody to the Sansa. BUT, after I disconnect my Sansa and after I wait for it to finish “refreshing your media”, it still then tells me that I need to synchronize to listen to my subscription tracks. Super frustrating. 

I would dearly love to avoid formatting my Fuze because re-loading it is a drag. Here is a bit more info if it is helpful to a Sansa guru:

I’m running the latest Rhapsody software (4.0).

Have tried this on two of my licensed PCs (one running Win 7 and one running Vista. Same Result.

Am running latest Fuze firmware (02.03.33A)

Of my 8GB internal memory, only 316MB is free

On my 8GB micro SD card, about 2GB is free 

The only other relevant info I can think of is:

  • When I connect my Sansa, Rhapsody reports that it is “updating sansa fuze internal memory” and does this for about 1-2 minutes each time I connect it.  
  • I tried removing my micro SD card and connecting with Rhapsody then to see if the card was the problem, but I get the same result without the card in my Sansa
  •  I tried setting my Fuze to MTP mode and then Rhapsody would not see the device, but when I set it to “auto detect” Rhapsody sees it fine.
  • Again, inside the Rhapsody software, with the Sansa connected, everything appears to work 100% fine. It sees all my tracks, it lets me add and delete tracks, it reports that licensing is successful when I license the device and so on.

THANKS so much to you and everyone who might assist me with this problem

Ah, I’ll let you in on the secret handshake to reset the Secure Clock.  Normally,this is done in that last step, when you transfer one track to the device.

Open the Rhapsody 4 client, and plug in your Fuze.

Now for the tricky part.  Crack your knuckles, and ready your fingers.  Press and hold the [Ctrl] + [Shift] keys, then right-click on the Fuze in the Sources pane.

There you go.  Select Reset Secure Clock. 

See if the device is now happy.

If all else fails, use the Format command on the Fuze, which will erase all media from the device, then start anew by first authorizing, and transfer a few test tracks.

My theory is that something is amiss with your secure clock…  Let me know how it goes!

Bob  :stuck_out_tongue:

Neutron Bob: It worked!!!   I was sure I was going to have to format and re-load 16GB of music, so I am very, very much in your debt. Thank you! Wish there was something I could do to repay you. Not sure what I know a lot about that YOU need help with…?    :smileyvery-happy:

And now for a rant: It is RIDICULOUS that Sansa and Rhapsody allow foolishness like this. It’s why Ipod is so big – because it just works and people just want to listen to the music. I pay my $15/month and so I shouldn’t have to spend hours troubleshooting and visit forums where gurus like Neutron Bob know all the obscure tricks… It’ll serve Rhapsody right if spotify eats their lunch as they have such buggy stuff…

THANK YOU, Neutron Bob!! 

THANK YOU Neutron Bob.  After spending an afternoon trying everything else, I finally saw you post and followed your simple instruction around resetting the internal clock.  It fixed it.  Can’t thank you enough.

Neutron Bob rocks!!  Thanks!