SSD Plus not visible on HP 655 laptop

In the past I have used a number of Sandisk SSDs to replace HDDs in laptops but this one has me stumped!  

I purchased a 240GB SandiskPlus and cloned via a USB/SATA cable with Macrium then tried it in my HP 655 Win 10 laptop.  Although the SSD has several partitions and what looks like a full file system to Windows explorer the drive was not recognisable, I repeated using a different cloning program (EasUS) and same result.  

On closer examination it appears that my HP laptop cannot even see the SSD in the bios ( I repeated the experiment with a known working Sandisk 120GB SSD from another laptop and that was invisible too).  I have changed what settings I could on the laptop bios (legacy boot  etc but no option available for AHCI) but my laptop (with an Insyde H20 bios) seems incapable of recognising your devices.   Before you send me off to HP do you have any suggestions?



in that case what you can try is to test the ssd on another computer to see if there its detected normally. If not then you are sure that the ssd is defective and needs to be replaced.

if the ssd then its detected normally by the other pc then it seems that the host configuration has something that prevents the ssd to work on there

Yes it is visible when installed in another laptop.  I wanted to check for any suggestions from Sandisk begore I do battle with HP.  I can imagine their response will be that the SSD is somehow incompatible.   Here goes…


Are you using an USB cable for this ? Is it possible to switch to a internal SATA port or change a SATA cable ?

It’s plugged into the internal SATA 3 on the HP655 laptop and it is nowhere to be seen on the bios screens.  When you try to boot up the the screen just says “no bootable device found”.  If I put the same SSD into a Packard Bell laptop it loads up with Win 10 no problem in a few seconds.

I have tried disabling secure boot, legacy mode etc and makes no difference.  I was wondering if the bios is misinterpreting the fast response of the SSD as some sort of error, if I put a SATA 3 HDD (from which I had cloned the system onto the SSD) in the same slot it works fine.

HP have made useful suggestions liek “have you plugged it in properly!!”

Any suggestions welcome.

ps the SSD has the latest firmware according to Dashboard.

Sorry to say this but I think the problem is more with your system then since the drive did work on another PC

One suggestion I  can make is to update BIOS and driver

Bios is at latest level and drivers are not relevant until you can load an OS!   I have been researching this problem and certain computeres have problems with SSDs (not just SanDisk) , it’s as if the SATA spec is being misinterpreted somewhere along the line since you never hear of a compatibility problem with HDDs.  My current theory is that the SSD is responding too quickly for the controller hardware and this is being misinterpreted.  As to how you fix that…  

SSD of my gaming laptop is not suitable. I don’t know which company made this, but this is just pathetic

Investigate all Samsung inside strong state drives (SSD) and channel by highlights, audits and cost to locate the best SSD stockpiling for your PC or work area more details… :

Never attempted YouTube Vanced however you can look at it their highlights to check whether may help. I’ve perused somewhere else best YouTube application out there so I’ve been thinking about to attempt to perceive what the furor is about.