SSD not able to use after secure erase

My SSD is not able to use after perform a secure erase.
The incident is like this.
I would like to format my SSD (with Win 10 install)
I took the drive out from my desktop and put in an external enclosure.
I connected it to my laptop and used SanDisk SSD Dashboard to perform Secure Erase.
After the Secure Erase, I realized that the files are still there. I try to perform another secure erase but it said it was password protect. The issue is as describe below.

I ignored the error and put it back to my computer. I tried to install Win 10. However, I found out I cant create partition.

It said 

_ we couldn’t create a new partition. error 0x80042453 _

I tried to use DISKPART.

It showed me. I fail at the Create Partition part. It said

_ Diskpart has encountered an error the request could not be performed because of an i/o error _

When I plugged it into my laptop, under the disk management, it said the drive need to be initiated. However, I failed to initiate it due to I/O error.

Please let me know how do I able to use the SSD again.

I try to unclock the SSD as mentioned in the article. However, I checked with a few computer, I did not see any option to enter the HDD/SSD password.

Thank you.

I got this error too

_ we couldn’t create a new partition. error 0x8007045d _

Hi, in my case, the command hdparm on linux has worked!

sudo hdparm --security-disable ssd123 /dev/sdb

In my case, the password was ssd123.


SanDisk SSD asking for drive password after performing Secure Erase

Each time a Secure Erase command is issued to a drive, the SanDisk SSD Dashboard sets a temporary password on the drive. The default temporary password is set to “sandisk123” OR"ssd123" OR “test”. If the secure erase completes successfully, this password is removed from the drive automatically. However, if power is removed or lost during the erase operation, the temporary password may not be cleared properly.
To unlock the SSD, enter the temporary password sandisk123 OR ssd123 OR test

Customer should enter the bios and there should be a screen for hard drive / SSD password"