SSD Dashboard bricked drive due to app crash

I hve two Ultra II 480GB drives recently purchased.  After performing some benchmarking and testing of one drive, I decided to Secure Erase it using SSD Dashboard v1.4.1 (latest as of this post).  In the middle of the Secure Erase procedure (right after the confirmation prompt), SSD Dashboard application crashed (Windows displayed notification of the app crash).  After restarting the PC and SSD Dashboard, the SSD is no longer accessible or cannot be written to; SSD Dashboard reports there is a Secure ATA password set on the drive.  Tried the bootable USB tool, it can’t write to the drive, either.  I assume this is due to the Secure Erase procedure crashing and leaving the SSD in an invalid or ‘locked’ (i.e. bricked) state.

My system is very stable and as follows:

Intel Pentium G3220 (no overclocking)

Intel H97 chipset (Asrock mobo)

8GB DDR3 RAM (no overclocking)

Windows 7 Professional 64-bit SP1 with all updates

Latest (or very recent) drivers available

If it matters, when this happened, the SSD was plugged through a USB 3.0 enclosure or drive dock.  Not through the SATA controller ports on the mobo.  I tried plugging the SSD into the SATA ports on the mobo but it won’t boot at all beyond the POST screen (I assume because the drive is ATA Secure Locked).  Event logs of the app crash implicate the fault is tied to NET Framework (unhandled exception) 4.0.x.  I have NET Framework 4.5.2 installed with all patches/updates as of this post.

1 Like

Hi. I know this was posted quite some time ago, but I’m having exactly the same issue with my new Ultra II 960GB SSD. The process of Secure Erase was interrupted, and ever since the SSD seems to be ‘broken’. Can’t format it, can’t make partitions, can’t write or read anything and Dashboard says it’s locked with Secure ATA.

Did you manage to solve the problem in the end? All help would be useful.

When you perform a “Secure Erase”, The Dashboard needs to set a password at the begening of the process and remove the password at the end. If you interrupt the process, the device is left with a password protection.

The password is:  ssd123

Thank you very much for your quick reply. Just one (maybe stupid) question. Where can I ‘unlock’ it? Because Dashboard says: “delete the password and try again” yet I can’t find the option to actually fill in the password… Neither in the disk manager of windows (which doesn’t show the SSD as locked).

It’s in the BIOS settings.

My intention is to switch the current HDD in my laptop with the new SSD. Does this mean I have to put in the SSD first (which is completely empty and not partitioned, but locked), then enter BIOS, unlock the password, put the HDD back in and then continue preparing my SSD for the installation process? Or is there an easier way to do this? My apologies for the questions, I just want to make sure I don’t make any more mistakes.

I don’t think you can enter a BIOS password when the drive is in a USB enclosure so yes the process you mentioned is what you will likely need to do. 

If you need to clone your current drive, you should be able to perform that while the SSD is pssw protected.

@elsv wrote:

Did you manage to solve the problem in the end? All help would be useful.

Hi, since it had been less than 30 days since purchasing the drive I just requested a replacement from Newegg via RMA.  Sent it back and got a new one in return.

I tried it in BIOS, but had the following issue: There’s an option ‘Drivelock’, which I guess is what I need. I can check and uncheck whether the drivelock password is asked at startup, but this doesn’t influence anything. If I choose to change the drivelock password, I get the message “Drive is locked”, but no opportunity whatsoever to even give the correct password, only an “OK” button. Really strange. So I have no clue of how to continue from here on.

Any suggestions are always welcome, thanks already for all the help.

1 Like

@georgealon: I’ve tried this with cloning software but always get some kind of error.

Have you tried EZ Gig IV?

If that doesn’t work, try AOMEI Backupper.

I’ll give it a try, thanks.

For some reason, I wasn’t able to install EZ Gig IV. When using AOMEI Backupper to clone, I got the exact error message:
“Information Code:6
The partition table on the disk was updated fail as other programs locked the partition table, please close other programs and retry.” No other programs were open, I rebooted and reconnected the disk but I didn’t help.

I’m afraid it seems hopeless… Although I’d rather just solve the problem, I can’t see how, so I’m going to take tcsenter’s advice and try and get a replacement. Anyway, thank you for the help everyone!

Oct 2016: Same here

Sandisk X400 512GB, attached to USB 3.0 Adapter Icy Box IB-AC603 UB31

connected to an USB2.0 port with Win7 PC.

SanDisk SSD DashBoard 1.4.3 crashed while “Secure Erase”  

and now the X400 is ATA Secure Password Protected!

(No other programm crashed on this PC since I can remember!)

Installed internally in another BIOS PC the BIOS PW prompt shows up instantly after power-on,

but neither “sandisk123” nor “ssd123” are the correct password.


Ah, bummer indeed :\ Well, I have to say that the customers’ service worked like a charm for me. I was helped straight away and after I returned my SSD, they sent me a new one immediately. I’d recommend doing this unless there’s valuable data on the disk of course…

Thank you for your kind replay.

The SSD is actually already RMA’ed.

But far from “immediate”: 7 to 10 days processing time, while I need the SSD working inside a machine.

Customer Support was very responsive and friendly, but could not remedy, what the Dashboard software has broken.

Too many hours wasted. :frowning: