SSD 240 event log errors. Drive failing?


I have an Extreme 240GB SSD which is approximately 1 year old. It’s installed in a Dell XPS 15 laptop (L502 X) as the boot drive (C:) running Windows 8, while the original drive has been moved to the CD bay. It has been running without error for several months and has been performing well. The drive has approximately 40% disk space free.

The BIOS has been updated to the lates version (A12) and I am running the latest version of the Sandisk firmware (211 ?)

In the past 2 weeks however my laptop has started freezing, crashing and requiring hard reboots. It has become unusable as these crashes occur after a few minutes of use.

I have tried running chkdsk but this has never completed successfully. Examining the eventlog shows the following errors frequently:

The device device/ide/iastor0 did not respond within the timeout period
The shadow copies of volume C were aborted because of an IO failure on volume C
The platform firmware has corrupted memort across the previous system power transition

It appears that the drive is failing after a very short period of use.

Are these error messages indicative of a failing drive?
Are there any Sandisk diagnostic tools that you can provide that will diagnose the issue?
Would a full format and reinstall fix these issues

Any help would be much appreciated as I was extremely satisfied with the disk before these issues started to occur.

Ciaran O’Neill

download the sandisk ssd toolkit and see if there are any issues in the SMART attributes. if you see any value that is not pass the SSD should be replaced. 

you could always try a secure erase and reinstall. if the issue is with corrupted data that should take care of it. if you see issues in the SMART attributes the SSD should be replaced. 

Hmm, I ran the SSD toolkit but most of the attributes had a status of N/A

The only ones that had a value were:

Raw Read Error Rate - Pass

Retired Block COunt - Pass

Reallocation Event Count - Pass

Life Curve Status - Pass

SSD Life Left - Pass

I’ve tried refreshing it and these are the only ones with values. Should I be seeing values for more of the attributes?

If all the SMART shows as pass the drive itself should be OK. I would try a secure erase and reinstall and see if the issue continues. If it does I would seek warranty replacement for the SSD