Song Titles, Albums, Artist Editing

I have all my songs named in folders on my computer and when I drop them in the Fuze they are renamed to Track 1, 2, 3, etc.  How do I prevent this?

I sync all mine in a program so I can get the correct ID tags.  I use Windows Media Player – it’s easy for me.  Then I can make sure that each song is labeled correctly or even change it if I want to (for example, I change some genres instead of creating a playlist, then I can add to it as much as I want).  I’ve also used Media Monkey, but WMP just seems easier for me.  Load CD, change ID tags if desired, Rip then Sync.

By default, Sansa players navigate only by ID3 tags, not file or folder names. But the last Fuze firmware update added folder navigation as well. Go to Music>Folders to choose folder navigation.

A free program called mp3tag

has a nice function, Convert, which will turn filenames into ID3tags. 

When you install it, allow it to add itself to Windows context menus. Before you use it the first time, reset one default: under Tools/Options/Tags/Mpeg make the Write option ID3v2.3 ISO-8859-1. Sansas like that format best. Make sure you save that change.

Now, right-click on one of your folders, highlight all the files and click Convert, choose Filename to Tag. It will give you possibilities on what you want to put into the tags–for instance, if yours are 01-First Song Title it will do that. With all the files highlighted you can also put Artist and Album into all the tags at once. 

if you have rhapsody choose the song from your library right click it select edit track info then click on track details the name the song click apply then ok finnally retransfer the song to the fuze

I just drag the Artist folder (with Album folder and mp3 Tracks nested inside) out of my Itunes Music folder and drop it in the Music folder on my Fuze. The Artists, Albums and Track names are all there when i browse the Music menu.  They are also accessible via Music>Folders