"Setup was unable create a new system partition" error installing Win7


I’ve just purchased aSanDisk Extreme 120Gb SSD (model SDSSDX-120G-G25), and when attempting to install Windows 7 I get a error “Setup was unable create a new system partition or locate an existing partition” when selecting the partition to install to.

I’ve already tried various DISKPART commands to clean the drive, create the partition, format to NTFS and make it active, but to no avail.

I’ve also made sure no other drives are connected except the DVD drive for my Windows disc.

I’m using a Gigabyte GA-P35-DS3 motherboard, plugged into one of the ICH9R Southbridge SATA ports, and I’ve switched AHCI mode on already.

Anybody have any ideas before I send the drive back?


Do not create anything with diskpart. Let Win7 installer do it.

I assume you can see the partition you have created with disk part? In Win7 installer - 1) Delete every partition you have on your SSD 2) create a new partition - it will also create another 100GB parition for the OS need - that’s ok. 3) Install Win7

That’s what I expected would work - I’ve never needed to use diskpart before when installing Win7. But no matter what I try, it gives me the same error, even when letting the installer run onto an unallocated partition.

If I try the New Partition option from the installer, it only creates one partition - an 111.8Gb Primary partition. No second 100Gb reserved one.

Have you ever used this disk before? If you did, was there an OS installed on it or you just used it for data? From your post it sounds like you have never used it before, just making sure…

You may want to perform a secure erase in any case. Also, some EFI BIOS have an option to boot from a CD/DVD drive in EFI mode. Make sure you do NOT use that option. This creates all kind of problems during installs. Use legacy CD/DVD mode.

Yes it’s a brand new drive - it’s never been used in any other machine (I hope!).

I don’t see any settings for EFI mode in the BIOS at all - would it come under any other name?

I’ve got a replacement CD/DVD drive to use (this one has been playing up for a while anyway) - would that make any difference?

In such a situation, you can clean the entire SSD using diskpart and this will ensure that the boot sector and system reserved partition is also cleaned. Try using the following method to clean the SSD and use the windows automatic partitioning to create partition for the installation of the operating system.

  1. Insert the windows 7 DVD into the DVD drive.
    2.On the disk selection screen, press SHIFT+F10. A Command Prompt window opens.
    3.Type diskpart, and then press ENTER to open the diskpart tool.
    4.Type list disk, and then press ENTER. A list of available hard disks is displayed.
    5.Type sel disk number, and then press ENTER. number is the number of the hard disk that you want to clean. The hard disk is now selected.
    6.Type det disk, and then press ENTER. A list of partitions on the hard disk is displayed. Use this information to verify that the correct disk is selected.
    7.Make sure that the disk does not contain required data, type clean all, and then press ENTER to clean the disk.

All the partitions and all the data on the disk is permanently removed.
8.Type exit, and then press ENTER to close

  1. Continue istallation of Windows OS by using automatic partitioning scheme rather than creating partitions yourself.

This worked for me in a similar situation. Hope will work for you as well. Best of Luck


Yep. Tried that about 5 times now in different configurations of BIOS settings, plugging into different SATA ports etc. etc.

Thanks for your help guys but I think It’s just a duff drive and/or motherboard and/or alignment of the planets or something.

As a first experience of SSD drives, this is pretty crap.

Does the drive work from your current windows install when connected as a secondary drive?  If it works there, it may be an issue with the windows 7 installer.  One thing to check is if the windows 7 install disk has ahci drivers (or working ahci drivers) for your motherboard chipset.  There should be a point during the install where you can install custom drivers from a disk.  You might want to try getting the latest AHCI drivers for your MB and installing them during that point (or slipstream them onto a custom windows 7 install disk using RT seven lite.

Otherwise it sounds like you just got a lemon.  Sorry to hear that.

Thanks dude. I’ll try viewing it in Windows tomorrow on the old working drive’s installed copy of Win7 and see what it does. I never thought of that.

The copy of the installer I’m using is of Windows 7 Ultimate SP1 straight from an MSDN account (although burned to a nice cheap DVD), so I figured it was up to date driver-wise.

AHCI-wise, it didn’t work before I even switched the BIOS into “use AHCI mode” so I don’t know about that. It just hasn’t worked no matter what configuration I’ve used. Same error every time.

I’m semi-tempted to try a Linux install too - see if it works. I don’t know diddly-squat about Linux though. I guess it’s not even a conclusive test - I mean, I really need Windws 7 on this machine.

* Does it sound like a MB problem?

* Would creating a USB-bootable version of Windows 7 help?

I’m just very sick of waiting 10-15mins for the Windows 7 setup to get itself in gear every time. And the more sick I get, the more tempted I am to send the drive back. But if it’s something daft like the Windows Installer then I can look at different options. I don’t want to replace a perfectly good drive for no reason.

I agree here with Slartibartfast. A corrupt install media can also be a proabble cause. As far as AHCI drivers are concerned, Windows 7 has Microsoft AHCI drivers. You can also check your motherboard support page to check if they provide customized AHCI drivers for your motherboard. AHCI is always the recommended mode for the SSD.

Also, if you can attach the SSD as an additional storage and see if the operating system allows you to create partitions on the same. Atleast this will help us rectify if the windows installer is creating a problem or the SSD.

EDIT: It is best to give linux a shot. It is worth :wink:

Download a free copy of fedora and try installing the same with minimum packages to see if you are able to do so.

Seriously, frustrating it can be.

  * Does it sound like a MB problem?


I’d say doubtful.  It sounds like you had the same problem in IDE mode (these drives work fine as IDE drives, they’re just slower), and your computer has otherwise been working fine in IDE mode.


  * Would creating a USB-bootable version of Windows 7 help?


I’m no expert on the windows installer, but I’d say probably not.  It’s just going to load the same stuff into memory regardless of the source.  I guess it’s possible something got messed up when you burned to CD-R, but I wouldn’t put much on that being the problem.  


Getting up to date drivers for the installer is the more important bit.  I remember had to do some gymnastics with drivers to get my non-sp1 windows to recognize my drive in AHCI mode, but they really ought to have gotten up to date drivers into SP1.  SP1 came out last year, the P35 came out way before that.

Hooo boy. Now I feel silly.

I had a 4Gb pen drive sat in one of the front USB ports that I hadn’t noticed. Windows Installer was trying to create its 100Gb partition to that I presume, because… well… Microsoft

Anyway, thanks for everyone’s time. I’ve got Windows 7 installed and working now. I’m gonna go hang my head in shame.

Hah, well, glad you got it working

elny16 solution worked like a charm thank you soooo much for sharing :slight_smile: happy installing