Win7 x64 installed once but won't Re-install to my SSD

I recently installed Win7 x64 on my Sandisk Extreme 120GB and the system worked well. Then one of my other programs started locking up, so I decided to clean the SSD and re-install Win7 x64. (My motherboard is EFI)

The Win7 disk will not re-install on the SSD, and I receive the following error message: “The disk has an MBR partition; on an EFI system it can only install to GPT disks.”

When I try to use Disk Management to change the SSD drive to GPT, the option is grayed out.

Please advise how I can re-install Win7 x64 to my SSD.

Thanks

Scott Clark

can you delete and recreate the partition using your install disk?

If the Windows installation GUI does not allow to convert a disk to GPT I would use the recovery console from the Win7 install CD and give the command line tool diskpart a try.

I has the option to convert an MBR disk to a GPT disk: 

http://technet.microsoft.com/en-us/library/cc738416(WS.10).aspx (see section “Using a command line”)

I had this when reinstalling Win 7 64bit on my SSD repeatadly. 

Had to delete the whole SSD Partition, then reformat. also delete the ‘hidden’ 200mb or so partition on there.

Worked just fine after, took 2 mins.

Rich