SecureAccess crashing at startup on macOS Catalina

Since I updated my MacBook from Mojave to Catalina SecureAccess just crashes a few seconds after launch.

I tried it on a USB stick and a portable SSD both with the newest version of SA and I even tried different file systems, since I first encountered the issue on my NTFS formatted SSD (macOS has natively only read compatibility with NTFS, but with some tools can write too), so i tried exFAT and FAT32 too with the same result.

Another thing I observed/tested:

When I used the Windows version to create a Vault on my SSD with a password and some files in it and then opening it on the MacBook via the mac version, SA didn´t crash but after typing in my password i got an error message saying the vaullt could not be loaded. But when I open it on Windows again everything is working.

My guess is that because of some changes to filesystem permissions made in Catalina the mac version of SecureAccess needs an update. But it could as well be some wierd issue with my MacBook, so it would be great to get some feedback if someone else has this problem too or even knows a solution to it.



Presently there is no solution to your problem. macOS Catalina is causing great hardships to other users as well and in many ways.

Apple has not released enough patches to clear a lot of errors.

So I would advice wait untill patches are released or downgrade to your earlier macOS version.