Secure Access V2 Invalid Archive

Hello all, hope someone can help.

I have been using the Sandisk Cruser 32gb USB stick for around 6 weeks without any hitch.

I simply have a spreadsheet with my passwords  secure in the vault, with a single unique password to acces the vault.

Up until today it has worked perfectly, but now when I insert the stick and open SanDiskSecureAccessV2_win.exe

the first thing to appear is a small box which displays ‘invalid archive’. It has an ‘OK’ button, which I press and then the familiar program opens.

Once I enter my password, my Vault opens in the background (which is empty) but in the foreground I get a box which displays ‘A Problem occured’.

With the content displaying:

A promlem occured during the execution of this application.

Please click OK to report this problem or Cancel to quit.

If you have this same problem more often and can tell us how to reproduce it, please contact

Please download the latest beta from our download page and verify id the problem is still in the latest beta. The download link for beta releases is at the bottom of the download page.

Problem date:

Filename: mainwindow.cpp (11205)

Function: showAddFileScreen condition ENCFileSystem::getinstance()->getltemAt(0)

PLease help, as I have tried on a my desktop PC and a laptop and both the same.

Thank you,




in that case the sithauth.enc file is corrupted and you will not be able to recover the vault. In my opinion in would be better if you would contact the Sandisk support directly to receive help on this matter.

you can contact them directly under this link

Thanks for the quick reply. I cant beleive what you have just said, for 2 years I had them stored on a free 2gb promotional usb stick no problems. I decide to think about security so went for this SanDisk USB stick with the encrytion software and you tell me it sounds like it has a fault and my vault is gone? **bleep**! It had every password I possess and I had it solely on this stick.

I am screwed - thanks SanDisk. I am also in Australia so when I am awake the support centre isn’t.

Thanks again Deponia, just pray I can recover them.

Try running a CHKDSK command on the flash drive.  You may have removed it before Windows finished updating its FAT.

I had it solely on this stick.

Important things need backups.  A password protected ZIP file on your hard drive would work for a backup.  Hopefully the CHKDSK command solves the flash drive problem.

Hi, are you still interested in recovering your data or you got rid of your Vault and/or USB Stick?

I can help you save it if you are still interested in recovering your data.