Secure Access V2 Invalid Archive

Hello all, hope someone can help.

I have been using the Sandisk Cruser 32gb USB stick for around 6 weeks without any hitch.

I simply have a spreadsheet with my passwords  secure in the vault, with a single unique password to acces the vault.

Up until today it has worked perfectly, but now when I insert the stick and open SanDiskSecureAccessV2_win.exe

the first thing to appear is a small box which displays ‘invalid archive’. It has an ‘OK’ button, which I press and then the familiar program opens.

Once I enter my password, my Vault opens in the background (which is empty) but in the foreground I get a box which displays ‘A Problem occured’.

With the content displaying:

A promlem occured during the execution of this application.

Please click OK to report this problem or Cancel to quit.

If you have this same problem more often and can tell us how to reproduce it, please contact

Please download the latest beta from our download page and verify id the problem is still in the latest beta. The download link for beta releases is at the bottom of the download page.

Problem date:

Filename: mainwindow.cpp (11205)

Function: showAddFileScreen condition ENCFileSystem::getinstance()->getltemAt(0)

PLease help, as I have tried on a my desktop PC and a laptop and both the same.

Thank you,