SDHC 4Gb doesn't work on my Fuze

I’ve a Fuze 4Gb - FW rev. 01.01.22F

  1. My Fuze doesn’t recognize .mp3 files on 4Gb SDHC memory card.

  2. I tried to upgrade the FW to latest 01.02.26 rev, after that, my Fuze doesn’t turn on, To turn-on it I have to try and try again moving the ON-OFF slider many times. When I succed in turning-on my fuze it recognizes the files on SDHC and everiting works with the new FW but If I turn it off, again I can’t restart it and I have  to try and re-try as before to turn it on.

What I can do to solve at least the first problem?

What’s the brand name of your SDHC card?  

Did you try starting it without the card in the player?  Does it still give you these problems?

If it works fine without the card, then you might have a faulty card (or some other compatibility issue with it).

If it has the startup problems with or without the card, then it sounds like something weird occurred when you updated the firmware.   If I were you, I would format the player and the card (making sure you have your music backed up somewhere else as this will erase everything) and re-install the latest firmware. Hopefully you just suffered some sort of glitch during your first update.  

If you do this and still experience start-up problems then there’s some other problem here.  Hopefully this will fix it.  The new firmware has been working fine on my (and many others) Fuze’s so it shouldn’t be an issue with the firmware.

Once the firmware is reinstalled, try your Fuze again (without the card) to see if it works.  Then try inserting your card in it.

Let us know if this doesn’t help. 

Sorry for the dalay of my answer…

  1. I solved the problem with the SDHC card. There was something wrong in the .mp3 tags so I couldn’t see song. I solved the problem setting againg the .mp3 tags on my PC and after that I was able to see the songs on my fuze.

  2. Problem with newer FW revisions is confirmed with or without SD card. At the moment I’m happy with FW rev. 1.01.22As soon as I’ll be able to back-up my music I will try formatting the playe.