SDHC 32GB Class 4 Card -- New, Not Working

Hello. I bought a SanDisk 32gb Class 4 SDHC card here in Taiwan to use in my new Canon S95. I took it on a moist backpacking trip, where it worked fine, and then down to the sunny beaches of the south, where it worked fine. On our way back home, as I was looking at the pictures, I got a “Memory Card Error” message. I cannot format the card, it is not recognized when the camera is plugged in via USB, nor is it recognized by Device Manager, or when I put it in the card reader slot of my Asus R500V laptop with Windows 7. I blew out both slots in the computer and the camera, to no avail. Except once, when it was plugged into the computer, and I was able to edit some of the pictures. But when I tried to delete a picture, it took a minute, and then my (rather new) computer blue screened. I haven’t gotten it to read since rebooting. Is there any hope for my card? Or for the pictures on it?

Unfortunately, it doesn’t sound like it. But if it helps, I believe it was just a coincidence when it failed; I doubt the moist or warm environment had anything to do with its failure.