SD64 Ultra won't allow deletion or format

I have a year old

Mobile Ultra microSDXC 64GB UHS-I Class 10

that all of a sudden would not allow me to delete certain files. That is if I deleted them on my SGS5 Smartphone the system seemed to delete them and next time I opened the directory the files where back again. Same behavious when I inserted the card in a Transcend USB-Adapter and attached it to my Macbook.

Same thing when trying to format to SD card. Formatting it with different recovery partition tools seemed to work ok but content of the card remained unchanged. Try OS/X’s disk utilities, same result. Tried SDFormatter-App recommended by SanDisk, ran full format fine w/o errors, but card is stimm unchanged, all files visible.

Any ideas?

Thx Ferdinand


in that case the card seems to be write protected and this is a hardware failure of the card. You can replace the card within the warranty with sandisk through this link

You mentioned using a Mac. Unless you empty your Trash while the card is still connected via a card reader, etc. your mac will only delete the Finder references, not the actual files themselves. Try emptying your Trash while the card is still connected and see what happens.

I have the same card as OP and same problem.

I use the card in my carcam, actually I have 2 carcams, front and rear, both with same card.

Noticed one of the camera little lights was not flashing indicating the camera was not recording. This obviously was not good and defeated the whole point of having carcams.

Checked the camera that was not working and found that the card had stopped recording. Did some tests and like the OP could not format or delete any files.

The card is under a year old so should be under warranty, unfortunately I’m in Thailand and the warranty replacement service does not cover Thailand.

This is obviously not good. These cards are expensive and supposed to be top of the range so what can I do to get a replacement.?

How reliable are these cards anyway? Obviously using one in a carcam i’t’s important that they are ultra reliable, no point in being let down by a faulty card in the case of an accident.

Not happy. :frowning:

Same here, a 07/2014 purchased 64GB microsd ultra card. Can read it just fine, but no more writes!

I am asking support for a replacement, however I don’t want to send my data to them…