Sandisk 32Gb class 4 MicroSD

Heloo, Ive got a problem with 2 of the a.m. Mirco sd cards.

All data (AVI-Files) on it is not ereasable any more (the switch is set correctly).

While using the explorer to delete the files, they are shown deleted, but reinserting the cards all data is there again. 

I’d tried it on two PC (Windows 7 and Windows XP) but no change.

Any Ideas what to do?


You could try formatting the card.

You could try formatting it.

I’d tried that too but no change

Then you’re going to have to give more information about your situation/problem. Formatting (if done correctly) erases everything.

I am having a similar problem with my Class 4 16GB micro SD card. Even with using file shredder software, i am unable to erase old data or add new ones. But i am able to read all the files on the card. Help, else i am forced to throw this card away!

You too are going to have to give more to go on. Just saying something doesn’t work doesn’t help anyone try to diagnose your problem or help find a solution.

Sorry, what more information do you need?

I’ve got the same problem. I’ve got an HTC Desire (phone) using a 32GB Sandisk MicroSD card which has worked perfectly for about 2 years. Then suddenly at some point over the last few days, it’s gone weird. I am unable to permanently delete any files from the card. I’ve tried all of the possible ways of accessing/connecting the card that I can think of:

  • I try on the phone directly,

  • I connect the phone to a computer and mount the card - on my MacBook Pro, or I mount it on my wife’s Windows 7 laptop,

  • I take the card out and use an SD adapter in the card slot on the Mac, and in the Windows laptop

  • I use the card in an adapter in an external card reader and connect to via USB the Mac and the Windows laptop.

Every method I use allows me to delete the files, or so I think.

When I then put the card back in my phone, all the deleted files are there again. So I repeat the process and the same thing happens.

I then try to scan the card (connected via any of the above methods) using the Mac OS Disk Utility and it gives me the message:

Verify and Repair volume “Untitled”

Checking file system** /dev/disk3

** Phase 1 - Preparing FAT

** Phase 2 - Checking Directories

** Phase 3 - Checking for Orphan Clusters

24610 files, 473456 KiB free (29591 clusters)

Volume repair complete.Updating boot support partitions for the volume as required.

So then I try to delete files - still no joy. Then I try to format the disk via whichever method and again, the card looks like it’s formatted but when I put it back in the Desire and/or mount it on a Mac/Win laptop all the files are still there.

I’m not sure what other info I can give you but please help. Surely a Sandisk card, used very carefully, should last more than 2 years?? The reason I’m trying to delete files is that the card has only 462 MB left on it and I’m unable to backup my phone’s contents due to lack of space!

Hi, we have the same issue, my 32 gb class 4 that I bought it from australia cant delete permanently the files and cannot be formatted.  The only problem is I can’t find the receipt but i still have the package.  I paid 149.95 for the memory card.  I thought buying Genuine would last however it didn’t last for me. Now I’m using my 16gb that I bought from amazon 3yrs ago,

Im hoping Sandisk would replace it because I’ve been using their products…

@michaelchoverma wrote:


Im hoping Sandisk would replace it because I’ve been using their products…


They will replace it if it is still under warranty (5 years I believe), but not simply because you are a loyal customer.

Contact them here:


New South Wales Time
M-F | 8a.m - 6p.m

1 800 262 504