Sandisk Ultra 64GB Micro SDXC1

Hi, I bought the memory mentioned on the subject from Amazon on Dec 18th 2012 and since a few days ago my phone started to show a message indicating that the camera was unable to store photos on the external SD, I though it was my phone so I didn’t pay attention at first but then i release that i deleted some files (pictures and documents) from the SD and after a while the files appeared again so after trying everything i decided to check other options and i did a backup then tried to format the sd card, the format was ‘succesful’ however the files were still there i removed the sd card and plugged to my MAC and tried to format there but the result is the same, the files are there, i am sure the adaptor is not in the lock position I download a software from here [1] to my mac and tried both options, quick and slow but no luck, there is no error but still the files are there and everything i copy to the memory gets deleted eventually, it’s like the sd card is frozen some how and always revert to the same state, I think it could be damaged, however i can read from it without any problem so i don’t know if there is something else anyone can recommend me to try. Thanks


:smiley:   Hi Danielvm,

_ Dear member of SanDisk Community, welcome. _

_   _

Please, see link:


Regards, Alfred.