SD micro stuck as write protected

I have a sandisk ultra plus 16gb micro sd and it it used as a media storage device on my Samsung Galaxy S4. It worked fine until a few days ago. I go and delete files but when I go back into the file Explorer they are back. I tried it from the file Explorer on the phone (tried it with a galaxy s7 as well), connected it to the computer and tried it there and pulled it out and connected it to the computer directly and the same result every time. I tried to format it but it says that Windows cannot complete the format. When I connected it to my pc through the S7 I got the notice that the source was write protected.

I don’t know how it became write protected and wanted to know how to remove the write protection. It doesn’t have a switch on it and it is virus free.

http://kb.sandisk.com/app/answers/detail/a_id/6971/

Looks like it is a faulty card. Submit an online RMA request to check warranty status.

Why do I get a “The disk is write-protected” message when I transfer files to my microSD card?

Image SOLUTION 1 - Unlock the memory card

If you are using a microSD to SD adapter, make sure the  Lock switch on the left side of the adapter card is slid up (unlock position).

You will NOT be able to modify or delete the contents on the memory card if it is locked.

SOLUTION 2 - Toggle the lock switch.

If the lock switch is loose and moves easily It is likely the switch is sliding to the locked position as the card is placed in your host device. In this case the card will need to be replaced.

ImagePlease contact SanDisk support to check warranty status.


SOLUTION 3 - Check the mobile device settings
Some mobile devices have a feature to lock the card.  Please check with your mobile device manufacturer for instructions to unlock it.
Image

NOTE: If the above steps do NOT resolve the problem or if the lock switch is missing or broken, please back up your data and request a replacement using our online web form.